Topic locked

Unity 5.1.1 Not recognizing Camera

June 25, 2015 - 2:56pm #1

Helo All

My Unity project stopped working on my iPhone. Tha Camera doesnt seem to be being accessed

It still works from with in Unity using Unity Remote so I know the set up is still good

but I seem to be getting no Cam access on the iPhone / though in settings I have granted acess.

 

All the various threads on this are published a while ago and have me oing into XCode to add code, but are quite confising

 

Please Help

Thanks

~be

 

Unity 5.1.1 Not recognizing Camera

July 2, 2015 - 6:53pm #10

Thanks,I have got the same problem before.And it has been solved by your solution by setting graphics APIs = OpenGL ES2.0

Unity 5.1.1 Not recognizing Camera

June 30, 2015 - 11:57am #9

Well, if so, you should re-create a new empty Unity project, then import the Google Cardboard to show those files/folders. And delete them yourself :)

Unity 5.1.1 Not recognizing Camera

June 30, 2015 - 11:47am #8

Thank you !

I had also done the import of google cardboard.

But I also deleted it.

It would be very hard to start with a new scene @ this point.

Did you find what files specifically it replaced?

Thnx!

 

Unity 5.1.1 Not recognizing Camera

June 30, 2015 - 11:19am #7

Hey,

I found the problem, from another post which is also related to the error "VideoBackgroundConfig with screen size of zero received, skipping config step".

It was my fault. I was going to integrate Google Cardboard SDK with Vuforia SDK. So I imported the google cardboard package.

Even I did not do anything with Google Cardboard yet (just import), but there were some other files placed in the Plugin folder, and the Google Cardboard App controller override the Vuforia App Controller, and Vuforia did not work as expected. Follow the other answerd post, I realized where is the problem come from.

So make sure you start with a clean project before integrating anything else :)

Thank you.

PS: the post I mentioned is here: https://developer.vuforia.com/forum/vuforia-40/camera-only-shows-black-screen (which is answered 1 day ago!, lol)

Unity 5.1.1 Not recognizing Camera

June 30, 2015 - 11:14am #6

FYI,

This happens only in Release Build from Unity 5.1.1p2,

When I export xcode project as Debug Build it works.

 

 

Unity 5.1.1 Not recognizing Camera

June 30, 2015 - 10:27am #5

Same problem here with Unity 5.1.1f1 :(, on my iPod touch 5, 

I tried with the Image Target sample. When I toggle on/off the Auto focus setting, the flashlight is on, so I think the camera works.

But the screen showed black. I found these logs from XCode:

...
cameraDeviceInitCamera
2015-07-01 00:17:32.438 xxx-game[3131:268046] *** -[AVCaptureVideoDataOutput setVideoSettings:] - videoSettings dictionary contains one or more unsupported (ignored) keys: (
    Height,
    Width
)
cameraDeviceGetVideoMode
Using default scene scale for device: 1
Vuforia.QCARAbstractBehaviour:ConfigureVideoBackground(Boolean)
Vuforia.CameraDeviceImpl:Init(CameraDirection)
Vuforia.QCARAbstractBehaviour:StartQCAR(Boolean, Boolean)
Vuforia.QCARAbstractBehaviour:Start()
 
(Filename: /Users/builduser/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 65)

2015-07-01 00:17:32.501 xxx-game[3131:268046] ERROR/AR(3131) 2015-07-01 00:17:32: VideoBackgroundConfig with screen size of zero received, skipping config step
cameraDeviceSelectVideoMode
cameraDeviceStartCamera
markerTrackerStart
objectTrackerStart
Trackable tarmac lost
Vuforia.TrackableBehaviour:RegisterTrackableEventHandler(ITrackableEventHandler)

What do you think?

PS: I did same settings as what you said in previous post (OpenGLES 2.0, IL2CPP, Universal)

Unity 5.1.1 Not recognizing Camera

June 29, 2015 - 11:03am #4

Have you verified that the Vuforia Samples work correctly on your device ?

as far as I can tell, Vuforia works correctly on iOS with Unity 5.1.1, provided that the Player Settings are set as I mentioned in my previous post.

If the samples work correctly, then it might be simply an issue originated by an incorrect upgrade from a previous version of Vuforia and/or Unity.

You may also want tocheck the migration guide:

https://developer.vuforia.com/library/articles/Solution/How-To-Migrate-a-Unity-Project

 

 

Unity 5.1.1 Not recognizing Camera

June 29, 2015 - 10:07am #3

Alessandro

Thank you !  But this doesnt work. The build fails when I set it to Universal. When I do  everything else Open GL2 & IL2CPP it works but the AR from Vuforia doesn't show.

Sorry it took a while to respond but I was checking everything

~ be

Unity 5.1.1 Not recognizing Camera

June 26, 2015 - 5:45am #2

You may want to check the Unity 5.1 PlayerSettings for iOS:

  • Graphics APIs =  OpenGL ES 2.0 (uncheck "Automatic" and remove any other graphics API,  as OpenGL ES 2.0 is the only supported one in Vuforia 4.x)
  • Scripting backend: make sure it is set to IL2CPP
  • Arcitecture: make sure it is set to Universal

 

 

 

Topic locked