Log in or register to post comments

Unknown type name 'namespace'

May 2, 2014 - 5:34am #1

After some difficultly I was able to start incorporating the Vuforia code in my existing app. As I worked my way through it, more and more of it would compile and be included properly. And then suddenly this line of code in Matrix.h stopped working...

namespace QCAR

{

 

Poking about a bit I found that Xcode wanted to know this was C++, so I changed the file type, trying both C++ Source and C++ header, but this did not help.

 

Any ideas?

Unknown type name 'namespace'

May 25, 2015 - 7:25am #6

Hi,

Im also having same issue when i tried to use Vuforia sdk. 

Please help me.

Thank you.

Unknown type name 'namespace'

April 3, 2015 - 4:16am #5

Someone could solve this problem?. I have 20 errors about namespace when I tied to integrate it in my own Xcode project and I can't solve it. 

I would be grateful if someone could help me to solve it.

 

Thanks

Unknown type name 'namespace'

May 2, 2014 - 6:13am #4

And now the original unmodified sample apps in a different folder don't compile either.

*sigh*

Unknown type name 'namespace'

May 2, 2014 - 6:08am #3

I take that back. All references to namespace appear to cause errors.

 

Unknown type name 'namespace'

May 2, 2014 - 5:52am #2

Ok this is interesting... this error ONLY occurs if I import Matrices.h into SampleAppSession. If I comment out that import I get errors about the missing matric types, but all the other warnings and errors go away...

Log in or register to post comments