Log in or register to post comments

URGENT: Color shift on 4S despite fix implmentation

September 21, 2012 - 7:44am #1

We have a project due to launch ASAP and despite replacing the libQCAR.a as instructed in the sticky for iOS 6 compatability we are still experienceing color shift in the camera feed.  We may not be able to to an entire update of Vuforia in the project if it is needed as we had to customize aspects of the plugin for this project. 

 

We are building under Unity 3.5.5 with Xcode 4.5 and after the updated libQCAR.a from version 1.5.9 of Vuforia we are tracing 1.5.8 in the console at runtime.

 

Anxiously awaiting direction.  Thank you guys.

 

 

2012-09-20 17:21:30.354 APPLICATION_NAME_HIDDEN[742:907] -> registered mono modules 0xbd2830

-> applicationDidFinishLaunching()

QCAR Extension version 1.5.10

2012-09-20 17:21:30.457 APPLICATION_NAME_HIDDEN[742:907] INFO/AR(742) 2012-09-20 17:21:30: QCAR SDK version 1.5.8

Mono path[0] = '/var/mobile/Applications/1F14E0B6-AE9D-4BB0-B07E-A3BB992B5C8E/APPLICATION_NAME_HIDDEN.app/Data/Managed'

 

URGENT: Color shift on 4S despite fix implmentation

September 21, 2012 - 10:40am #3

Thank you very much for the response.  It might be a good idea to make the fix write-up a little more prominent on the step that the correct file for this fix is located in the iOS version and NOT the Unity version.  That said, I'm working fine now and greatly appreciate the direction.

 

URGENT: Color shift on 4S despite fix implmentation

September 21, 2012 - 7:56am #2

Hi pixelplacement

we are tracing 1.5.8 in the console at runtime

This is a clear indication that it is picking up the wrong library, so please check and validate this through finder.

There was another Unity developer on this thread having similar problems:

https://ar.qualcomm.at/content/compatibility-issues-ios6-easier-fix

..which turned out to be that he thought there was a new Vuforia Unity Package released with the iOS fix - there is not.

Instead you need to install the new native sdk 1.5.9 and get the library from there, and then insert that into your Unity project in the path specified in the message.

Let me know how you get on, as this should work.

HTH

N

 

Log in or register to post comments