Log in or register to post comments

VideoPlayback landscape problem

May 8, 2014 - 3:34am #1

HI,

 

I'm having so much problem using Videoplayback in Landscape mode. I'm using vuforia latest version for iOS. What I did was I disabled all other orientation leaving LandscapeLeft enabled. Then I changed change a certain line:

[vapp initAR:QCAR::GL_20 ARViewBoundsSize:viewFrame.size orientation:UIInterfaceOrientationLandscapeLeft];

The app runs okay on Landscape mode (views looks okay) but when it runs the AR Camera it 's only 1/4 of the screen (or smaller). What am I missing?

I even tried interchanging the width and height of viewframe on the VideoPlaybackViewController.mm and the camera became half of the screen. 

Please help.

 

Thank you very much.

VideoPlayback landscape problem

May 29, 2014 - 2:34am #4
I have tried but not yet fixed the problem. 
I attached the display screenshot of this problem.
 
Is there anyone have an idea about the topic?
Otherwise, it is a too basic issue in iOS programming?
 
 
AttachmentSize
Image icon Screenshot 2014.05.29 18.30.20.png479.35 KB

VideoPlayback landscape problem

May 19, 2014 - 5:28pm #3
Hello.
I also face the same problem.
 
I have changed all UIInterfaceOrientationPortrait to UIInterfaceOrientationLandscapeLeft and
replaced the height and width in configureVideoBackgroundWithViewWidth.
 
Could anyone give us some advises?
Thank you.
 

VideoPlayback landscape problem

May 15, 2014 - 7:53am #2

Hi,

I have same problem.

 

Please help.

 

Thanks.

 

Log in or register to post comments