Log in or register to post comments

Vuforia 9.6.3 + iOS 14: CloudReco NOT working

December 24, 2020 - 6:06am #1

In Vuforia 9.4.6, there waas a different error: targetFinder->startRecognition() was crashing. Now, with 9.6.3 that seems to be working fine again, but when we call finder->enableTracking(*cloudRecoResult), it crashes (every time).

Our code is the same it's been working for the past year, based on: https://library.vuforia.com/articles/Solution/How-To-Implement-Cloud-Reco.html (C++ version). Same code is working fine in Android, so this is definitely an issue within iOS SDK.

Vuforia 9.6.3 + iOS 14: CloudReco NOT working

April 28, 2021 - 6:26am #7

Hi @mcotora,

The email is

.

As I've mentioned before, the exact same codebase is working on Android but it's not working on iOS. Android has never stopped working, but iOS has stopped working on 9.x. (we're currently using 8.5.8).

It would be great if you could share an example of CloudReco for native iOS (the only available is for Unity at this time).

Thanks

Vuforia 9.6.3 + iOS 14: CloudReco NOT working

April 27, 2021 - 5:56am #6

Hi @pepemarriot,

I successfully tested the Cloud Reco functionality on native using iOS. The code is similar to what you wrote. My understanding is that we did not make any changes to Cloud Reco.

As you have a PRO license, I would want to continue the investigation over a case. Could you please confirm what e-mail address to use? (vuforia engine account e-mail address)

This being said, I would need also to know the last VE version on which the app worked for both iOS and Android?

Thank you.

Vuforia Engine Support

Vuforia 9.6.3 + iOS 14: CloudReco NOT working

March 25, 2021 - 5:12am #5

Vuforia 9.6.3 + iOS 14: CloudReco NOT working

March 24, 2021 - 10:14pm #4

Hello All

Someone please guide me how to use Vuforia Cloud Recognition for Vuforia 9.8  & Unity 2019.4.

Please!

Vuforia 9.6.3 + iOS 14: CloudReco NOT working

March 18, 2021 - 1:36pm #3

Hi @mcotora, here you have a summary of the code:

Vuforia::TargetFinder* targetFinder;

std::string lastTargetId;

bool Example::init() {

    Vuforia::TrackerManager& trackerManager = Vuforia::TrackerManager::getInstance();

    Vuforia::ObjectTracker* imageTracker = static_cast<Vuforia::ObjectTracker*>(trackerManager.getTracker(Vuforia::ObjectTracker::getClassType()));

    targetFinder = imageTracker->getTargetFinder(Vuforia::ObjectTracker::TargetFinderType::CLOUD_RECO);

    if ( targetFinder->startInit( user.c_str(), secret.c_str() ) ) {

  targetFinder->waitUntilInitFinished();

}

    int resultCode = targetFinder->getInitState();

    // resultCode is always Vuforia::TargetFinder::INIT_SUCCESS, so nothing wrong here

    targetFinder->startRecognition();

}

void Example::Vuforia_onUpdate(Vuforia::State& state) {

    auto queryResult = targetFinder->updateQueryResults();

if (queryResult.status == Vuforia::TargetFinder::UPDATE_RESULTS_AVAILABLE && queryResult.results.size() > 0) {

        auto result = queryResult.results.at(0);

        if (!result->isOfType(Vuforia::CloudRecoSearchResult::getClassType())) {

            return;

        }

        const Vuforia::CloudRecoSearchResult* cloudRecoResult = static_cast<const Vuforia::CloudRecoSearchResult*>(result);

        if (cloudRecoResult->getTrackingRating() > 0) {

            auto newTrackable = targetFinder->enableTracking(*cloudRecoResult);

           

            targetFinder->stop();

           

            if (newTrackable != nullptr) {

                lastTargetId = result->getUniqueTargetId();

            }

        }

    }

}

 

We've tried with Vuforia's SDK 9.8.5, and this is still happening. A couple of additional notes:

- Exact same code (C++) is working fine in Android

- We haven't changed this flow within our app during the past year

- You have removed cloud reco from the iOS samples, in order to understand how you make it work (code is only available for Unity)

Vuforia 9.6.3 + iOS 14: CloudReco NOT working

February 10, 2021 - 5:53am #2

Hi, 

Could you please provide  log file when the app is crashing? or if possible a barebone project with the cloud reco implementation in which the issue is reproducible?

Thank you.

Vuforia Engine Support

 

Log in or register to post comments