Log in or register to post comments

Vuforia ImageTarget does not appear on ios

October 27, 2015 - 3:20pm #1

Hello everybody! Can someone help me?

 I'm using Unity with Vuforia and the thing is, I have a simple scene with vuforia where the ImageTarget loads normally on unity editor or android, but when I export to ios the camera loads normally, but the ImageTarget simply does not appear.

Do somebody know how to solve this?

Thank you!

Vuforia ImageTarget does not appear on ios

October 30, 2015 - 7:22am #6

Dataset Record could not be loaded and cannot be activated.

I totally missed that line. That line indicates a problem in loading your dataset.

Could you try the Image Targets sample, and if that works, could you try importing the StonesAndChips dataset of the sample into your project and see if that's loaded correctly ?

 

Vuforia ImageTarget does not appear on ios

October 30, 2015 - 7:16am #5

I will check these two options!

 

By the way, this specific line:

line 81  Dataset Record could not be loaded and cannot be activated.

Is this supposed to happen?\

 

Thank you for the fast response!

Vuforia ImageTarget does not appear on ios

October 30, 2015 - 7:03am #4

Thanks for the additional details. 

The logs do not show anything wrong (Vuforia seems to initialize successfully).

 

  1. Could it be that the camera image is simply not in focus, preventing the target from being detected ? 
  2. Have you tested the Image Targets sample app from the Vuforia Samples ? does it work okay ?

 

Vuforia ImageTarget does not appear on ios

October 30, 2015 - 6:39am #3

Unity version: 5.2.1f1

Vuforia version: 5

MAC OS version:  X 10.11 (El Captain)

IOS device: Ipad 3

IOS version: 8.4

 

 

I took the logs from xcode when I ran the game:

2015-10-30 07:16:47.118 luz[754:260669] -> registered mono modules 0x133a960
-> applicationDidFinishLaunching()
PlayerConnection initialized from /private/var/mobile/Containers/Bundle/Application/08A9524B-7E59-4858-8274-BE8A01B2D59B/luz.app/Data (debug = 0)
PlayerConnection initialized network socket : 0.0.0.0 55000
Multi-casting "[IP] 192.168.25.17 [Port] 55000 [Flags] 2 [Guid] 155061694 [EditorId] 849712765 [Version] 1048832 [Id] iPhonePlayer(Le):56000 [Debug] 0" to [225.0.0.222:54997]...
-> applicationDidBecomeActive()
Requesting Native Resolution
Renderer: PowerVR SGX 543
Vendor:   Imagination Technologies
Version:  OpenGL ES 2.0 IMGSGX543-115.5
GLES:     2
GL_OES_depth_texture GL_OES_depth24 GL_OES_element_index_uint GL_OES_fbo_render_mipmap GL_OES_mapbuffer GL_OES_packed_depth_stencil GL_OES_rgb8_rgba8 GL_OES_standard_derivatives GL_OES_texture_float GL_OES_texture_half_float GL_OES_texture_half_float_linear GL_OES_vertex_array_object GL_EXT_blend_minmax GL_EXT_color_buffer_half_float GL_EXT_debug_label GL_EXT_debug_marker GL_EXT_discard_framebuffer GL_EXT_draw_instanced GL_EXT_instanced_arrays GL_EXT_map_buffer_range GL_EXT_occlusion_query_boolean GL_EXT_pvrtc_sRGB GL_EXT_read_format_bgra GL_EXT_separate_shader_objects GL_EXT_shader_framebuffer_fetch GL_EXT_shader_texture_lod GL_EXT_shadow_samplers GL_EXT_sRGB GL_EXT_texture_filter_anisotropic GL_EXT_texture_rg GL_EXT_texture_storage GL_APPLE_clip_distance GL_APPLE_color_buffer_packed_float GL_APPLE_copy_texture_levels GL_APPLE_framebuffer_multisample GL_APPLE_rgb_422 GL_APPLE_sync GL_APPLE_texture_format_BGRA8888 GL_APPLE_texture_max_level GL_APPLE_texture_packed_float GL_IMG_read_format GL_IMG_texture_comp

ression_pvrtc 
OPENGL LOG: Creating OpenGL ES 2.0 graphics device
Initialize engine version: 5.2.1f1 (44735ea161b3)
WARNING: Shader Unsupported: 'Standard' - Pass 'FORWARD' has no vertex shader
WARNING: Shader Unsupported: 'Standard' - Pass 'FORWARD_DELTA' has no vertex shader
WARNING: Shader Unsupported: 'Standard' - Pass 'SHADOWCASTER' has no vertex shader
WARNING: Shader Unsupported: 'Standard' - All passes removed
Setting BehaviourComponentFactory
UnityEngine.GameObject:AddComponent()
System.Collections.Generic.IEqualityComparer`1:GetHashCode(T)
System.Collections.Generic.IEqualityComparer`1:GetHashCode(T)
 
(Filename: /Users/builduser/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 64)

Setting Unity version 5.2.1
QCAR Extension version 5.0.6
Initializing Vuforia...
2015-10-30 07:17:00.546 luz[754:260669] QCAR SDK version 5.0.6
2015-10-30 07:17:00.937 luz[754:260669] DEBUG/AR(754) UIView has CAEAGLLayer class
2015-10-30 07:17:00.938 luz[754:260669] DEBUG/AR(754) UIView does not respond to selector renderFrameQCAR
2015-10-30 07:17:00.938 luz[754:260669] DEBUG/AR(754) UIView has CAEAGLLayer class
2015-10-30 07:17:00.939 luz[754:260669] DEBUG/AR(754) UIView does not respond to selector renderFrameQCAR
2015-10-30 07:17:00.940 luz[754:260669] DEBUG/AR(754) Could not find a UIView with CAEAGLLayer layer class that responds to selector renderFrameQCAR
Vuforia initialization successful
System.Collections.Generic.IEqualityComparer`1:GetHashCode(T)
System.Collections.Generic.IEqualityComparer`1:GetHashCode(T)
System.Collections.Generic.IEqualityComparer`1:GetHashCode(T)
 
(Filename: /Users/builduser/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 64)

trackerManagerInitTracker
trackerManagerInitTracker
Creating a Mono Camera Configuration (Check for reflection)
System.Collections.Generic.IEqualityComparer`1:GetHashCode(T)
System.Collections.Generic.IEqualityComparer`1:GetHashCode(T)
System.Collections.Generic.IEqualityComparer`1:GetHashCode(T)
System.Collections.Generic.IEqualityComparer`1:GetHashCode(T)
 
(Filename: /Users/builduser/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 64)

2015-10-30 07:17:01.127 luz[754:260669] VideoBackgroundConfig with screen size of zero received, skipping config step
SetHint
System.Collections.Generic.IEqualityComparer`1:GetHashCode(T)
System.Collections.Generic.IEqualityComparer`1:GetHashCode(T)
System.Collections.Generic.IEqualityComparer`1:GetHashCode(T)
System.Collections.Generic.IEqualityComparer`1:GetHashCode(T)
 
(Filename: /Users/builduser/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 64)

SetHint
System.Collections.Generic.IEqualityComparer`1:GetHashCode(T)
System.Collections.Generic.IEqualityComparer`1:GetHashCode(T)
System.Collections.Generic.IEqualityComparer`1:GetHashCode(T)
System.Collections.Generic.IEqualityComparer`1:GetHashCode(T)
 
(Filename: /Users/builduser/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 64)

SetHint
System.Collections.Generic.IEqualityComparer`1:GetHashCode(T)
System.Collections.Generic.IEqualityComparer`1:GetHashCode(T)
System.Collections.Generic.IEqualityComparer`1:GetHashCode(T)
System.Collections.Generic.IEqualityComparer`1:GetHashCode(T)
 
(Filename: /Users/builduser/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 64)

dataSetExists
dataSetExists
Dataset Record could not be loaded and cannot be activated.
System.Collections.Generic.IEqualityComparer`1:GetHashCode(T)
System.Collections.Generic.IEqualityComparer`1:GetHashCode(T)
System.Collections.Generic.IEqualityComparer`1:GetHashCode(T)
System.Collections.Generic.IEqualityComparer`1:GetHashCode(T)
 
(Filename: /Users/builduser/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 64)

StartVuforia
System.Collections.Generic.IEqualityComparer`1:GetHashCode(T)
System.Collections.Generic.IEqualityComparer`1:GetHashCode(T)
System.Collections.Generic.IEqualityComparer`1:GetHashCode(T)
System.Collections.Generic.IEqualityComparer`1:GetHashCode(T)
 
(Filename: /Users/builduser/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 64)

cameraDeviceInitCamera
2015-10-30 07:17:01.202 luz[754:260669] *** -[AVCaptureVideoDataOutput setVideoSettings:] - videoSettings dictionary contains one or more unsupported (ignored) keys: (
    Height,
    Width
)
cameraDeviceGetVideoMode
2015-10-30 07:17:01.222 luz[754:260669] VideoBackgroundConfig with screen size of zero received, skipping config step
cameraDeviceSelectVideoMode
cameraDeviceStartCamera
markerTrackerStart
objectTrackerStart
Trackable vuforia lost
Vuforia.DefaultTrackableEventHandler:Start()
System.Collections.Generic.IEqualityComparer`1:GetHashCode(T)
System.Collections.Generic.IEqualityComparer`1:GetHashCode(T)
System.Collections.Generic.IEqualityComparer`1:GetHashCode(T)
System.Collections.Generic.IEqualityComparer`1:GetHashCode(T)
 
(Filename: /Users/builduser/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 64)

Trackable vuforia lost
System.Collections.Generic.IEqualityComparer`1:GetHashCode(T)
System.Collections.Generic.IEqualityComparer`1:GetHashCode(T)
System.Collections.Generic.IEqualityComparer`1:GetHashCode(T)
 
(Filename: /Users/builduser/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 64)

cameraDeviceGetVideoMode
cameraDeviceGetVideoMode
Setting up 1 worker threads for Enlighten.
  Thread -> id: 1085e000 -> priority: 1 
cameraDeviceGetVideoMode

 

Can you help me?

Thanks in advance!

Vuforia ImageTarget does not appear on ios

October 29, 2015 - 12:32am #2
  • what Unity version
  • what Vuforia version
  • what Mac OS version
  • what iOS device is affected
  • what iOS version is running on the device

 

Log in or register to post comments