Log in or register to post comments

Vuforia unresponsive

June 19, 2019 - 6:15pm #1

I built a pretty basic Vuforia AR app that works great on Android.

When I build for iOS I am having a major issue. Basically my menu just has 2 buttons. "about" and "AR".

The about button works great and is very responsive but when I tap AR it seems to hang the app (although sometime after say 20 seconds it does switch).

I am new to iOS and xCode and am wondering if there is a way to get debug information.

Any advice would be great.

Vuforia unresponsive

June 20, 2019 - 12:23pm #2

Hello,

Vuforia Engine 7.2 (and beyond) made changes to the initialization process that may impact the flow of your application. The default initialization behavior of Vuforia Engine is to download the latest device profile in order to deliver the best experience on the device.  Depending on the speed of the user's internet, this could add several seconds to application load. This only occurs the very first time the user launches the app and will not impact application loading in future launches of the app.

It is strongly recommended to allow the Vuforia Engine to fetch the latest device profile. Developers looking to disable this behavior should set the following hint before initializing Vuforia: VuforiaUnity.SetHint(VuforiaHint.HINT_ASYNC_FETCH_OF_LATEST_CALIBRATION, 1);

Additionally, we are tracking some open issues with Vuforia Engine and Unity 2019.1:

https://developer.vuforia.com/forum/unity/known-issues-unity-20191

Thanks,

Vuforia Engine Support

 

 

Log in or register to post comments