Log in or register to post comments

VuforiaRenderEvent crash

October 12, 2015 - 11:12am #1

Hello there.

I have an issue that reproduces only on iOS devices(on Android and Unity editor works just great). I have a game that uses Vuforia from time to time. Is based on multiple activities, one of them being an AR recognition. Because of this I have to remove the camera from the scene in order to save up the battery life.

Now, in order to do this I have a prefab of the camera and I'm adding it to the scene only when I need it, and then I'm unloading it (stoping the tracker, deinitialiing the camera and then removing the prefab from the scene). First time everything works great, the camera starts, the tracker works and recognizes the target and all is good. But, when I try to add it back to the scene, for a second use the app crashes. I have also tried several alternatives, such as changing the scene before loading the camera, not stopping the tracker and not calling the deinit function but everything fails and I get the same error.

Tech specs: Unity 5.1.3p2, Xcode 6.4 and it reproduces on every iOS device.

Here is a screen shot from Xcode with the error:

[img] https://photos-4.dropbox.com/t/2/AACzwj1O0Mgn3-uIdoXDZ-RDeehfaSLM2lgGi2FW-VRMbw/12/165289586/png/32x32/1/1444680000/0/2/vuforiarenderevent.png/CPK86E4gASACIAMgBiAHKAEoAygH/Ewk4-qIg4pnkQW4OR-hHV4a8ILdelHdHmr1KYKH3vXg?size=1600x1200&size_mode=2 [/img]

AttachmentSize
Image icon Screenshot 2015-10-12 18.52.54.png428.08 KB

VuforiaRenderEvent crash

November 12, 2015 - 3:50am #6

I tried this. But in this case, on Android, I get a black screen.

VuforiaRenderEvent crash

November 12, 2015 - 3:49am #5

.

VuforiaRenderEvent crash

November 11, 2015 - 7:33pm #4

The native camera resource behavior may differ on Android and iOS. Adding and removing the ARCamera from the scene may be causing a problem. You might try stopping the camera and re-starting it when needed.

VuforiaRenderEvent crash

November 11, 2015 - 4:16am #3

I do not switch scenes at all. I always work within the same scene. I tried changing scenes as a workaround but it didn't work out.

VuforiaRenderEvent crash

November 10, 2015 - 2:56pm #2

Are you trying to stop and deinit the AR before opening a new non-Vuforia Unity scene? If so, try just loading the new scene and not explicitly shutting down the AR.

Log in or register to post comments