Log in or register to post comments

X-Code QCARUnityPlayer.h error

September 13, 2012 - 8:13am #1

Just created a new project trying out the QCAR Video Sample package.


I get these errors in X-Code..    I've made sure there are no spaces,hyphens etc.. in my project name directory. 


#include "QCARUnityPlayer.h"

#import "AppController.h"

 

#import <CoreGraphics/CoreGraphics.h>

#import <QuartzCore/QuartzCore.h>

#import <UIKit/UIKit.h>

#import <Availability.h>

 

#import <OpenGLES/EAGL.h>

#import <OpenGLES/EAGLDrawable.h>

#import <OpenGLES/ES1/gl.h>

#import <OpenGLES/ES1/glext.h>

#import <OpenGLES/ES2/glext.h>

 

#include <mach/mach_time.h>

 

Any thoughts on this would really appreciated as i need to present this to a potental client tomorrow evening... 

 

 

 Regards,

           Mick

X-Code QCARUnityPlayer.h error

September 17, 2012 - 1:33am #5

Hi Mick,

Let me know how you are getting on as this problem sounds pretty weird.

If you are still having problems you can PM me with a link to your project and I will try to look at it this week to see if I can reproduce.

cheers,

N

X-Code QCARUnityPlayer.h error

September 16, 2012 - 12:55am #4

I found this helps (but does not fix the issue completely ) 

 

  1. Disconnect your device. 
  2. Delete the app from your device. 
  3. Quit xcode (Don't just simply close the window, quit it) 
  4. Delete derived data folder (~/Library/Developer/Xcode/DerivedData/-gbrvhlvwmpiobxdujegtghggrffp - or something like that) 
  5. Now start Xcode, connect device and run the project. It should work fine.

Also I read,  Try  clearing  UIRequiredDeviceCapabilities in Info.plist (but i can not find the "UIRequiredDeviceCapabilities"

maybe I am looking in the wrong list.. any ideas ?

 

Mick

X-Code QCARUnityPlayer.h error

September 15, 2012 - 6:38am #3

Hi,

       Thanks for the reply..   I have two main problems .. 

1.)  X-code throws an error after inital launch  .....  Definately weird since it only happens every 2nd or third time I build.

    I'm using   X-code v4.4.1  

sometimes I see this error when I hit Build.

"Warning  The file for the container that was at /Users/norikoimaeda2/AAR01/VideoTest/VideoTest/Unity-iPhone.xcodeproj/project.xcworkspace has disappeared. Do you want to re-save the container or close it? "

I hit re-save & then it builds and runs correctly ..... 

I am not sure how to delete the x-code cache  as I can't see the Library folder.. ( its hidden ) but I do see it when I navigate in X-code.. but can't delete as I can only navigate when saving a file so no option to simply delete..   :(

 

note: In Xcode I also tried  Product > Edit Scheme  "  & changed the executable file  note: I see two exectuable files with the same name "watchred" from the first in the list to the second in the list. 

My other problem is running a  M4V  video file.   Vuforia video sample runs fine.. I load my m4v file and I get the hour glass...  are there  special settings a video must conform to such as resolution, aac...  I'm using handbrake to create the m4v files..  they run fine on my Macbook pro. 

Regards,

          Mick   ( stressing out here as usual.. 18hr deadline till i meet up with clients to showcase this App. )

 

X-Code QCARUnityPlayer.h error

September 14, 2012 - 1:06am #2

Hi Mick

Sounds pretty weird - that subsequent runs do not work ...

Have you 1) tried cleaning the product before building and 2) tried stopping/deleting it from the device ?

You should not have to touch Library folder - also which XCode are you using?  One thing you might be able to try is to clear XCode caches?

N

Log in or register to post comments