Topic locked

Xcode Error

July 6, 2015 - 11:57pm #1

HI All,

I'm receiving an error which causes my iOS device to freeze when building to it. I have my own build but have also tested this on using imagetargets-4-2-3 to rule out any other issues. 

I've looked through the forums and online, but can't seem to find a solution. I have used the following versions to rule anything else out

Unity 4.6.5 with Vuforia 4.2.3 with Xcode 6.3.2

Unity 5.1.1 with Vuforia 4.2.3 with Xcode 6.3.2

Many thanks

 

 

AttachmentSize
Image icon xcode shot903.02 KB

Xcode Error

July 19, 2015 - 12:15pm #18

Hi AlessandroB,

Before I started doing anything drastic I followed your direction and removed the Library folder first, then launched Unity 4.6.7 the Library folder built again in the root as you explained and I then changed over to iOS from the default Windows standalone. 

I built to Xcode and then built to an iPhone 6 Plus iOS 8.4. Success!! 

Thank you for your tips and guidance. This has been a great help and finally we're back on the road to development again. 

 

Xcode Error

July 16, 2015 - 5:11am #17

Ok. Thanks for the confirmation that the samples work.

One tip for your project "cleanup": one thing that often (although not always) resolves issues like this (e.g. Unity version and/or Vuforia version upgrades) is to:

- close the Unity project

- delete the "Library" folder under your project root

- delete (if any), the "Temp" folder under your project root

- re-open Unity and let it re-generate the Library folder automatically

Hope it helps.

 

Xcode Error

July 16, 2015 - 5:00am #16

I've created a new project and used object and image targets. Now building to the latest version. 

So it looks like my project is at fault here with outdated or currupted files. 

Hopefully I can get sorted now I know where the problem was. 

Thank you for all your help. Now the task of digging through the project :(

Xcode Error

July 16, 2015 - 3:58am #15

The only setting which differs is the Target iOS Version - mine is set to 8.1 whereas yours is 5.1.1. I've duplicated your settings but the same error occurs. I'll try with a blank project and report back. Appreciate your support. 

Xcode Error

July 16, 2015 - 3:42am #14

Hi,

I've just tried once again with Unity 4.6.7f1 on Mac OS 10.10 and Xcode 6.4 with iOS SDK 8.4 installed,

with this project setup:

- create a new Unity project

- import the "ImageTargets-4-2-3.unitypackage" sample package

- set the iOS Player Settings as in the screenshot that I am attaching

- build and run

The app compiles, links and runs correctly in Xcode.

 

See attached screenshot of the Unity Player Settings for iOS.

AttachmentSize
Image icon Unity-iOS-PlayerSettings.png63.79 KB

Xcode Error

July 16, 2015 - 3:11am #13

Hi AlessandroB,

I've tested on 4.6.7 with latest Xcode and now run into this error. I've not added any other files such as eyewear so not sure why I would have these errors. I would have thought if there was an issue then Xcode would have picked this up in an earlier build.

AttachmentSize
Image icon Screen Shot 2015-07-16 at 11.04.56.png1020.59 KB

Xcode Error

July 15, 2015 - 12:42pm #12

Hi AlessandroB,

Not tried yet, but will certainly give it a go now. I'll report back when I have done so.

Many thanks 

Xcode Error

July 15, 2015 - 12:37pm #11

Have you considered upgrading to Unity 4.6.7 f1 or 4.6.7 patch p1 ?

Here I can build on iOS devices with iOS 8.3 and 8.4 installed, with Unity 4.6.7 and Xcode 6.4.

 

Xcode Error

July 15, 2015 - 12:16pm #10

In addition to my last comment, I have found that if iOS 8.3 is installed on the Apple device an error will appear when building in Xcode;

 

2015-07-15 20:10:52.146 demos[15485:3217491] -> registered mono modules 0x1019fd890

-> applicationDidFinishLaunching()

-> applicationDidBecomeActive()

Requesting Resolution: 1920x1080

Renderer: Apple A8 GPU

Vendor:   Apple Inc.

Version:  OpenGL ES 2.0 Apple A8 GPU - 53.13

GL_OES_depth_texture GL_OES_depth24 GL_OES_element_index_uint GL_OES_fbo_render_mipmap GL_OES_mapbuffer GL_OES_packed_depth_stencil GL_OES_rgb8_rgba8 GL_OES_standard_derivatives GL_OES_texture_float GL_OES_texture_half_float GL_OES_texture_half_float_linear GL_OES_vertex_array_object GL_EXT_blend_minmax GL_EXT_color_buffer_half_float GL_EXT_debug_label GL_EXT_debug_marker GL_EXT_discard_framebuffer GL_EXT_draw_instanced GL_EXT_instanced_arrays GL_EXT_map_buffer_range GL_EXT_occlusion_query_boolean GL_EXT_pvrtc_sRGB GL_EXT_read_format_bgra GL_EXT_separate_shader_objects GL_EXT_shader_framebuffer_fetch GL_EXT_shader_texture_lod GL_EXT_shadow_samplers GL_EXT_sRGB GL_EXT_texture_filter_anisotropic GL_EXT_texture_rg GL_EXT_texture_storage GL_APPLE_clip_distance GL_APPLE_color_buffer_packed_float GL_APPLE_copy_texture_levels GL_APPLE_framebuffer_multisample GL_APPLE_rgb_422 GL_APPLE_sync GL_APPLE_texture_format_BGRA8888 GL_APPLE_texture_max_level GL_APPLE_texture_packed_float GL_IMG_read_format GL_IMG_texture_comp

ression_pvrtc 

Creating OpenGLES2.0 graphics device

Initialize engine version: 4.6.5f1 (c2bb1d7d067c)

(0) In Level Loaded: 01.AF_Main_Menu

CompareFunc:EndInvoke(IAsyncResult)

UnityEngine.Debug:Internal_Log(Int32, String, Object)

UnityEngine.Debug:Log(Object)

SoundManager:HandleLevel(Int32)

SoundManager:OnLevelWasLoaded(Int32)

SoundManager:Setup()

SoundManager:Awake()

CompareFunc:EndInvoke(IAsyncResult)

End

Updating to iOS 8.4 seems to be vital for a working environment. 

Of course this is just presenting the issue with a workaround, not a long term fix. If there is something here which anyone knows is at fault please do add your comments. 

Hope this is of help to anyone.

Xcode Error

July 15, 2015 - 12:16pm #9

In addition to my last comment, I have found that if iOS 8.3 is installed on the Apple device an error will appear when building in Xcode;

 

2015-07-15 20:10:52.146 demos[15485:3217491] -> registered mono modules 0x1019fd890

-> applicationDidFinishLaunching()

-> applicationDidBecomeActive()

Requesting Resolution: 1920x1080

Renderer: Apple A8 GPU

Vendor:   Apple Inc.

Version:  OpenGL ES 2.0 Apple A8 GPU - 53.13

GL_OES_depth_texture GL_OES_depth24 GL_OES_element_index_uint GL_OES_fbo_render_mipmap GL_OES_mapbuffer GL_OES_packed_depth_stencil GL_OES_rgb8_rgba8 GL_OES_standard_derivatives GL_OES_texture_float GL_OES_texture_half_float GL_OES_texture_half_float_linear GL_OES_vertex_array_object GL_EXT_blend_minmax GL_EXT_color_buffer_half_float GL_EXT_debug_label GL_EXT_debug_marker GL_EXT_discard_framebuffer GL_EXT_draw_instanced GL_EXT_instanced_arrays GL_EXT_map_buffer_range GL_EXT_occlusion_query_boolean GL_EXT_pvrtc_sRGB GL_EXT_read_format_bgra GL_EXT_separate_shader_objects GL_EXT_shader_framebuffer_fetch GL_EXT_shader_texture_lod GL_EXT_shadow_samplers GL_EXT_sRGB GL_EXT_texture_filter_anisotropic GL_EXT_texture_rg GL_EXT_texture_storage GL_APPLE_clip_distance GL_APPLE_color_buffer_packed_float GL_APPLE_copy_texture_levels GL_APPLE_framebuffer_multisample GL_APPLE_rgb_422 GL_APPLE_sync GL_APPLE_texture_format_BGRA8888 GL_APPLE_texture_max_level GL_APPLE_texture_packed_float GL_IMG_read_format GL_IMG_texture_comp

ression_pvrtc 

Creating OpenGLES2.0 graphics device

Initialize engine version: 4.6.5f1 (c2bb1d7d067c)

(0) In Level Loaded: 01.AF_Main_Menu

CompareFunc:EndInvoke(IAsyncResult)

UnityEngine.Debug:Internal_Log(Int32, String, Object)

UnityEngine.Debug:Log(Object)

SoundManager:HandleLevel(Int32)

SoundManager:OnLevelWasLoaded(Int32)

SoundManager:Setup()

SoundManager:Awake()

CompareFunc:EndInvoke(IAsyncResult)

End

Updating to iOS 8.4 seems to be vital for a working environment. 

Of course this is just presenting the issue with a workaround, not a long term fix. If there is something here which anyone knows is at fault please do add your comments. 

Hope this is of help to anyone.

Xcode Error

July 15, 2015 - 10:00am #8

We have an iMac that had not been updated and was running an older version of Unity to be specific 4.6.5.f1 with the latest Xcode (as detailed in my last comment and tested building it. We have now been able to build to an iOS device. No other version of Unity will get this far, which is frustrating but at least this is a short term fix.

I rolled back a Macbook Pro to the same version of Unity and the most up to date Xcode and built again to the same device.

Is this a bug? are anyone else suffering the same issue? I don't see this problem as resolved but at least some answers for anyone else having the same problem.

Xcode Error

July 15, 2015 - 6:31am #7

Hi AlessandroB,

We're using the following versions;

Unity 4.6.5f1

Xcode 6.4 (6E35b)

Vuforia 4.2.3 Object Recognition & Image Target

Playmaker V1.7.8.3

Note: I understand that Playmaker can be an issue, but I've also tried with a clean project and just the ImageTarget or ObjectTarget demos and the same issue happens.

Tested builds on the following

iPhone 4 - iOS7.1

iPhone 5 - iOS8.1

iPhone 6 Plus iOS 8.4

Android Nexus build works fine, just iOS is causing the issues. 

Thanks 

Steve

 

Xcode Error

July 15, 2015 - 5:31am #6

One question:

What device, and what iOS version ?

 

Xcode Error

July 15, 2015 - 4:32am #5

Can anyone help with this issue? or at least point in the right direction? Still suffering the problem :(

Xcode Error

July 15, 2015 - 4:32am #4

Can anyone help with this issue? or at least point in the right direction? Still suffering the problem :(

Xcode Error

July 7, 2015 - 5:25am #3

   

Xcode Error

July 7, 2015 - 5:08am #2

Further information from the xcode console;

 

Requesting Resolution: 2048x1536

Renderer: Apple A7 GPU

Vendor:   Apple Inc.

Version:  OpenGL ES 2.0 Apple A7 GPU - 53.13

GL_OES_depth_texture GL_OES_depth24 GL_OES_element_index_uint GL_OES_fbo_render_mipmap GL_OES_mapbuffer GL_OES_packed_depth_stencil GL_OES_rgb8_rgba8 GL_OES_standard_derivatives GL_OES_texture_float GL_OES_texture_half_float GL_OES_texture_half_float_linear GL_OES_vertex_array_object GL_EXT_blend_minmax GL_EXT_color_buffer_half_float GL_EXT_debug_label GL_EXT_debug_marker GL_EXT_discard_framebuffer GL_EXT_draw_instanced GL_EXT_instanced_arrays GL_EXT_map_buffer_range GL_EXT_occlusion_query_boolean GL_EXT_pvrtc_sRGB GL_EXT_read_format_bgra GL_EXT_separate_shader_objects GL_EXT_shader_framebuffer_fetch GL_EXT_shader_texture_lod GL_EXT_shadow_samplers GL_EXT_sRGB GL_EXT_texture_filter_anisotropic GL_EXT_texture_rg GL_EXT_texture_storage GL_APPLE_clip_distance GL_APPLE_color_buffer_packed_float GL_APPLE_copy_texture_levels GL_APPLE_framebuffer_multisample GL_APPLE_rgb_422 GL_APPLE_sync GL_APPLE_texture_format_BGRA8888 GL_APPLE_texture_max_level GL_APPLE_texture_packed_float GL_IMG_read_format GL_IMG_texture_comp

ression_pvrtc 

Creating OpenGLES2.0 graphics device

(lldb) 

Topic locked