Log in or register to post comments

Vuforia behaviour is crashing Unity 2019.2.6f if it is enabled in scene

October 1, 2019 - 2:32am #1

Unity version : 2019.2.6f1

Vuforia version: Upgraded to 8.3.9 from package manager but still showing 8.3.8 in VuforiaConfiguration in Inspector.

Hi,

I have upgraded my Unity to version 2019.2.6f1 and vuforia version to 8.3.9.  After the upgrade my scene was keep crashing when I press play button.  After removing the objects from my scene one by one, I came to know that it was the Vuforia Behaviour on ARCamera which was causing this crash.  

I have tried to reimport everything again after deleting everything from Library but it didn't fixed the problem.  I have again removed the vuforia plugin and re-install it again from the unity package manager but still doesn't get any luck.  

I am attaching my editor.log file here for your reference.

Regards,

Jeetesh

AttachmentSize
Plain text icon Editor.txt81.31 KB

Vuforia behaviour is crashing Unity 2019.2.6f if it is enabled in scene

October 18, 2019 - 4:18pm #9

mocom wrote:

Hi,

 

Do you need any other information related to this.  As I am still facing the same issue.

 

Please let me know if I can fix this with any workaround. my ip birthday wishes tneb  I am really stuck up with this and waiting for the solution.

 

Can you let me know if it will take time or not until we will get a fix for this in the latest version.

 

Regards,

Jeetesh

Can you let me know if it will take time or not until we will get a fix for this in the latest version.

Vuforia behaviour is crashing Unity 2019.2.6f if it is enabled in scene

October 16, 2019 - 9:02pm #8

Hi,

Thanks for your reply.

Yes, that was strange that it is not happening in prior versions with me as I was using 2018.3.4f1 for long and did not encounter this problem in that version.

But after this version I was encountering in all subsequent versions.

My project path is :- /Users/apple/Desktop/Work/Viewa/JCH Repo/VIEWAANDROIDPROJECT which is similar to the previous path and there is no change in the project path.

In System Preferences->Security & Privacy->Privacy Tab.  I didn't see any camera in my privacy tab so that I can allow camera for Unity.  Is it available in mac book pro.  

As the bug is happening in Editor I have checked this on my mac book pro.

Regards,

Jeetesh

Vuforia behaviour is crashing Unity 2019.2.6f if it is enabled in scene

October 16, 2019 - 12:38am #7

Hi,

I looked over the release note of Vuforia and the bug you are referencing from unity seems not to be addressed or known.

In addition if this would be the bug that you where encountering, I would expect this also not to work in the prior version before upgrading to the recent version. An easy check would to confirm the project name that you are using. Could you please confirm?

Also did you check if Unity/Unity Hub has access to the camera? (System Preferences->Security & Privacy->Privacy Tab.  Select Camera and check Unity in allowed apps?)

Thank you.

Vuforia Engine Support

Vuforia behaviour is crashing Unity 2019.2.6f if it is enabled in scene

October 15, 2019 - 8:24am #6

I am still getting the same problem again and again.  I tried everything but still can't get rid of the error.  

I have then reported the problem as bug to Unity3D and they are saying that its a know issue at their end and please contact Vuforia for a solution.

Below is the link for the bug which is reported at Unity's end

https://issuetracker.unity3d.com/issues/os-x-unity-editor-crashes-after-clicking-play-on-a-vuforias-project-if-a-path-to-this-project-contains-non-ascii-symbols

Comment from Unity:-

"Unfortunately there's nothing we can do about this bug. Please contact Vuforia and say that this issue

has been investigated by Unity and identified as a bug in Vuforia. Providing the findings above to Vuforia

will speed up their resolution process."

Vuforia behaviour is crashing Unity 2019.2.6f if it is enabled in scene

October 11, 2019 - 1:41am #5

Hi,

The behavior that you are encountering is strange, I tried to reproduce it, however on my macbook Unity doesn't crash.

Setup is Unity 2019.2.2f1 with Vuforia 8.3.8.

Going over your steps, I noticed that you add the vuforia configuration to AR Camera. This step is not necessary.

Give it a try?

In addition, could you go under System Preferences->Security & Privacy->Privacy Tab.  Select Camera and check Unity in allowed apps?

Afterwards try it again.

Thank you.

Vuforia Engine Support

Vuforia behaviour is crashing Unity 2019.2.6f if it is enabled in scene

October 8, 2019 - 5:29am #4

Hi,

 

Do you need any other information related to this.  As I am still facing the same issue.

 

Please let me know if I can fix this with any workaround.  I am really stuck up with this and waiting for the solution.

 

Can you let me know if it will take time or not until we will get a fix for this in the latest version.

 

Regards,

Jeetesh

Vuforia behaviour is crashing Unity 2019.2.6f if it is enabled in scene

October 3, 2019 - 9:56pm #3

Hi,

I have upgraded from 2018.3.4f1 where every thing was working fine. But I have not directly upgraded to 2019.2.6f1 but have upgraded to one by one.  

I have tried creating a new project in version 2019.2.6f1 and added vuforia behaviour on the camera and when I play the same crash appears again.

Steps to reproduce

1. Create a new 3D project in Unity version 2019.2.6f1. ( Mac Book Pro)

2. Add the Vuforia version 8.3.9 from unity package manager. 

3. Add vuforia configuration to the camera.

4. Click Play button.  You will notice that Unity will crash without any warning.

Jeetesh

Vuforia behaviour is crashing Unity 2019.2.6f if it is enabled in scene

October 3, 2019 - 5:45am #2

Hi,

From which Unity version did you upgrade to 2019.2.6?

If it was an older version, you may have in the Asset folder the previous Vuforia installation which was not done via Package Manager. Could you please check?

In addition, please also create a new project add an ARCamera and let us know if you encounter the same behavior.

Thank you.

Vuforia Engine Support

Log in or register to post comments