Topic locked

Andtroid screen goes white

May 27, 2015 - 3:02pm #1

Vuforia SDK Version: latest -
Description with steps to reproduce:

So, the problem is: My app is compiling right and installing on any phone, but when the target is active the hole screen goes white. This doesn't happen in PC, just in the mobile app build. On the PC, testing whit my webcam, the 3D object shows right where it should be. Any help ?

-
Development OS (Mac OS X, Windows, Linux): Windows 8 64 bits -
Mobile OS and Version: Android 5.0 above -
Mobile Device Manufacturer and Model name: LG d805 -
Do the Vuforia Sample Applications show the same behavior?: No

Andtroid screen goes white

June 10, 2015 - 3:17am #6

UPDATE on Unity 5.0.x:

Unity 5.0.3 has been released and it includes the fix to the Unity 5 UI and rendering issues with Vuforia 4.2.3.

 

You can download Unity 5.0.3 from:

 https://unity3d.com/get-unity/download/archive

Andtroid screen goes white

May 28, 2015 - 9:54am #5

Sounds like the same issue discussed here:

https://developer.vuforia.com/forum/unity-3-extension-technical-discussion/vuforia-42-unity-501-ui-issue

you can try replacing Unity 5 materials such as "Standard" or "Standard (Specular)" with legacy shaders such as "Legacy/Diffuse" or "Mobile/Diffuse"; 

other shaders that might trigger the same issue are the "Bumped Diffuse" and all the shaders using Bump Mapping.

See the thread above for more details.

 

Andtroid screen goes white

May 28, 2015 - 6:21am #4

Yes, i had the same error, actualy the blank or white screen its kind of a texture of one the componentes of the 3D Model. I had a dinosaur model and suddendly the texture of the body were in fullscreen as you said. I´m not sure about the problem, some times i change the style of texture (diffuse, legacy, etc) and works, but not always :(

I´m still loking for a solution because also i have problems with the GUI (alike texture fail).  It's weird because i solve the problems of the GUI putting a 3D text on scene. I think we  have to keep working on the errors by our selfs  :(   because,  at this time i haven't found yet an official bug report or something.

Rgards.

Andtroid screen goes white

May 28, 2015 - 5:54am #3

I tried to put an image as texture of a plane 3d form to show up when the camera detects the marker and, wow, I found out the issue.  What happens is that the object come in full screen, not following the marker as it should. Do you know a way to fix it ?

Andtroid screen goes white

May 27, 2015 - 3:16pm #2

Hi there!

I had kind alike issue, it took a lot of time to resolve. First i thought it was a texture, like a normal or something, but it results that was a EmptyObject in the scene which has a rendered attached. I deleted the object and everything go normal, i'm not sure about the reason. Maybe you could look for something like that.

Hope this help to solve your problem. Regards.

Topic locked