Log in or register to post comments

Arcamera stucks

January 29, 2019 - 1:18am #1

Vuforia SDK Version: 7.0.57 -

Description with steps to reproduce: First of all in Vuforia Configuration on Vuforia Version there is no number there, so that's a little bit wierd, i can only read the version in \Assets\Vuforia\version. Isn't 7.0.57 little low for Unity 2017.4.18? how to patch that.

Main Issue:
When I add an ArCamera to my scene and import Vuforia and start my scene with the hololens on the ArCam gets stuck, i changed around with the settings to device type Digital Eyewear, both Vuforia and hololens.
I think something is wrong with my Vuforia I want to repair or reinstall it, delete everything and have a clean Vuforia.

Anyone excerienced this kind of problems? I cant use ArCamera/Camera with Vuforia from the start because after Vuforia Init the cam gets stuck... pls help -

Development OS (Mac OS X, Windows, Linux): Windows 10 64-Bit -

Mobile OS and Version: Windows 10 32-Bit -

Mobile Device Manufacturer and Model name: Microsoft Hololens -

Do the Vuforia Sample Applications show the same behavior?:

Arcamera stucks

January 31, 2019 - 2:44pm #5

Hello,

I don't understand your setup. Are you trying to use the HoloLens Emulator in Unity? If so, it is not supported by Vuforia.

Thanks,

Vuforia Engine Support

Arcamera stucks

January 30, 2019 - 2:59am #4

New Info I fixed the problem where there were no values in Vuforia Configuration window, i reactived my HP HD Cam and that fixed that problem, when i start with AR Camera it connects with my laptop camera, therefore i disabled vuforia play mode so the hololens is taken as camera.

Now I have the same issue on my PC as on the other PC too, when i start with Vuforia Behaviour activated the values stay at 0,0,0 when i enable vuforia while runtime the values reset to 0,0,0 and stay there. 

Arcamera stucks

January 30, 2019 - 2:16am #3

In Vuforia Configuration there was still no Version value there, nor any error message, nor any download link.

I downloaded the vuforia hololens sample, I created an ArCamera made it to my made camera and when i start from the editor, the ArCamera gets after a split second fixed values -> it stucks or freezes again

I uploaded pictures, from my issue, usually when i start the scene with a camera the values should change constantly with the hololens on, but if vuforia starts it starts to freeze

EDIT: We just tried something on a different PC, on that pc we got Unity 2017.4.18 with Vuforia 7.0.57(Version Value is in Vuforia Configuration) and we tried to use a ARCamere, after start all values where 0,0,0 (x,y,z) rotation also, then we tried ArCamera with vuforia behaviour checkbox disabled then we got the movement from the hololens as condinates, after we enabled vuforiabehaviour (StartVuforia) the values jumped to 0,0,0 and stayed so, it wasnt a stuck with changed codinates it was a reset then stuck on an other PC!

 

 

AttachmentSize
Image icon NoVersionValue.PNG4.93 KB
Image icon ArCamFixedValues.PNG39.54 KB
Image icon NoExceptions.PNG15.58 KB

Arcamera stucks

January 29, 2019 - 2:45pm #2

Hello,

I would suggest doing the following:

  1. Install a fresh version of the Unity Editor (2017.4.latest), with Vuforia support
  2. Upgrade Vuforia SDK using the instructions below
  3. Download the Vuforia HoloLens sample from the Asset Store

This will provide you with a 'clean slate' to again start your evaluation and testing.

Thanks,

Vuforia Engine Support

To upgrade the version of Vuforia embedded in the Unity Editor, please follow these steps:

  1. Open the Unity Editor
  2. Select Window->Vuforia Configuration
  3. If there is an error message about Vuforia not being enabled, please follow the instructions and restart this process
  4. If your version of Unity is eligible for a Vuforia update, you'll see a message and link to download the installer
  5. Download and extract installer executable from downloaded ZIP file
  6. Quit Unity Editor
  7. Run the installer executable
    • For Windows, select the folder that corresponds to the installed version of the Unity Editor that is eligible for the Vuforia update. Ex: C:\Program Files\Unity_2018.1.4f1
  8. Restart the same version of the Unity Editor in Step #1
  9. Verify the update in the Unity Editor via Window->Vuforia Configuration
Log in or register to post comments