Log in or register to post comments

Black borders in ARCamera view

March 2, 2018 - 2:42am #1

Vuforia SDK Version: 7.0.47 -

Description with steps to reproduce: I just updated my app from Vuforia 7.0.?? to 7.0.47, in Unity.

The last version had no problems, but with the new update I encountered a problem only with iPhone 8 and iPhone X (I tested also iPhone6, iPhone SE, iPhone 5 and iPad 4 retina). I see a black border (with iPhone X on top and bottom, with iPhone 8 also on left and right) in the ARCamera view; Canvas images that are in the border instead are not covered by the black border.

I tested the problem with a very basic app, and the results are in the screenshots I linked.
The border also change in size when I put the app in background and reopen it. With the iPhone 8 sometimes disappear (for example now I cannot reproduce anymore the problem)

Could you investigate?

I use Unity 2017.3.1p2
Vuforia 7.0.47
OPEN GLES2, Portrait, IL2CPP, no strip engine code, "defer system gesture on edges" all enabled, hide home button on iPhone X enabled
iPhone X IOS 11.2.5
iPhone 8 IOS -

Development OS (Mac OS X, Windows, Linux): OSX -

Mobile OS and Version: IOS 11.2.5 -

Mobile Device Manufacturer and Model name: Apple iPhone X -

Do the Vuforia Sample Applications show the same behavior?: Yes

Black borders in ARCamera view

March 2, 2018 - 11:57am #4

You should link a photo of your problem, I don’t understand the problem you say, and I don’t think is related to the black border bug

Black borders in ARCamera view

March 2, 2018 - 6:21am #3

I'd like to add that object placement on an image target is shifted with and without the black border.  When the black border is visible I believe the tracking is similar to Vuforia 6, without the black border (fresh app run, no backgrounding) the placement is wrong.



 

Black borders in ARCamera view

March 2, 2018 - 2:49am #2

   

AttachmentSize
Image icon IMG_0314.jpg188.3 KB
Image icon IMG_0315.jpg182.44 KB
Log in or register to post comments