Log in or register to post comments

black screen with newest SDK

March 10, 2016 - 6:05pm #1

Vuforia SDK Version: 5.5.9 -

Description with steps to reproduce:

Hello

 

   I am working with Unity 5.1.0f3 and 5.3.3 (Linux version Ubuntu 14.04) from what i understand both are compatible with vuforia.

   My device is the OPO running CM13 (android 6.0.1)

 

   From my expireance i am able to work with older vuforia versions with both unity versions and the same device, i can compile code right now and work just fine but when i use the new SDK 5.5.9 i get blank screen every time, even if i just try to render the camera no targets or anything.

  By the way targets are detected and i am getting the 3d object on screen but not the camera feed.

 

I tried lowest android version 4.0.3, Landscape Left, Rendering path Legacy deferred, OpenGL2, with the same results.

In Vuforia 5.06 and 5.0.10 i dont need to worry about all those settings like rendering path as forward works just fine, and other versions of android.

 

THank you

Chop

-

Development OS (Mac OS X, Windows, Linux): Android -

Mobile OS and Version: CM13 6.0.1 -

Mobile Device Manufacturer and Model name: One Plus One -

Do the Vuforia Sample Applications show the same behavior?: yes, i have tested samples so far as i just want to test the new sdk.

black screen with newest SDK

September 5, 2016 - 8:23am #11

HI :) : i want to share my case LOOK:

I got the black screen, some post say you should delete the vuforia.jar and the vuforiaUnityPlayer.jar on Plugins/Android (because the android SDK JAR crash)..... DONT DO THAT your androids will be copiled but when you start the app it will go to black.

SOLUTION:

Download a new oracle JAVA SDK 8 for windows 86 bit (32 BITS) change the java sdk on your unity 5 file for the new one

IT WORKS FOR ME.... hope this can be usseful for some one else :)

regards:

daniel guevara

black screen with newest SDK

March 14, 2016 - 8:16pm #10

Unfortunately i cannot switch OS in both situations but thank you for the support very impressed to be honest with the time replies.

I guess ill wait for new SDK or Unity updates.

 

Old SDK Still very good and i havent review it all :)

 

by the way CynogenMod is the default ROM that came with my device, it even has it on the back of the phone printed by factory.

But i understand the point that is to aim an android rom as clean as possible.

black screen with newest SDK

March 14, 2016 - 3:07pm #9

Our Vuforia Unity extension is currently only tested for use with Unity Editor on Windows and Mac OS. Custom Android ROMs are also not supported. We recommend that you try an official build of Unity for Win/Mac and an Android device with an official software build.

http://unity3d.com/get-unity/download/archive

 

black screen with newest SDK

March 14, 2016 - 10:06am #8

I understand your idea about what could be the problem but why the previous version worked just fine.

I cant blame CM13 becuase it works with old vuforia version, same for Unity3d linux, i am not able to install windows or Mac OS.

But ill check with the unity Team to see if they can help but i still believe its a SDK problem.

black screen with newest SDK

March 14, 2016 - 9:58am #7

Ok.

Then I can see 2 possible issues:

- Unity on Ubuntu, this is an experimental Unity build for Linux, not something officially supported (as of today)

- Your device has a CyanogenMod ROM, which is also an unofficial Android version.

One thing you may want to trying is to switch to Windows or Mac, install an official Unity version for Win or Mac and test the app in such setup.

 

black screen with newest SDK

March 12, 2016 - 5:04pm #6

I just want to let you know that my manifest.xml

 

<uses-sdk android:minSdkVersion="14" android:targetSdkVersion="22" />

 

so i changed as mentioned:

 

<uses-sdk android:minSdkVersion="16" android:targetSdkVersion="22" />

 

but the i got the same results.

any other ideas are welcome.

i am running ubuntu 14,04, unity3d linux version 5.3.3f1 Personal

black screen with newest SDK

March 11, 2016 - 6:34am #5

Yes, that is my device. (Wow pretty fast response)
Unity3d launch a version fully compatible with linux not using wine or any windows port this is full linux Unity3d.

I tested in 5.3.3 with the same results, if you need any logs or any specific information about my enviroment just let me know.

 

 

I will check the manifest for the line you mentioned tonight.

black screen with newest SDK

March 11, 2016 - 1:42am #4

black screen with newest SDK

March 11, 2016 - 1:41am #3

As an additional tip, check that your AndroidManifest.xml file, under your project 'Assets/Android/Plugins/' folder, contains this line:

 

<uses-sdk android:minSdkVersion="16" android:targetSdkVersion="22" />

 

If it does not include that, you can manually add that line, save the file, and rebuild the project and see if you still observe black camera.

 

 

black screen with newest SDK

March 10, 2016 - 6:27pm #2

Unity 5.2.4 is minimum supported version for Vuforia 5.5.9.

Log in or register to post comments