Log in or register to post comments

Camera issue : Red and blue colors are switched in camera on Xiaomi Mi9T

July 26, 2020 - 6:01am #1

Vuforia SDK Version: 9.2.8 -

Description with steps to reproduce: I created an app with two scenes, each scene with its own ARcamera. The app starts with everything working correctly but when I swish scenes and the second camera is loaded ( the first camera is unloaded) the colors switch. The reds become blue and the blues become red the greens are correctly displaying. Any fix ? -

Development OS (Mac OS X, Windows, Linux): windows -

Mobile OS and Version: Android 10 -

Mobile Device Manufacturer and Model name: Xiaomi Mi9T -

Do the Vuforia Sample Applications show the same behavior?: I haven't tested really

Camera issue : Red and blue colors are switched in camera on Xiaomi Mi9T

September 4, 2020 - 3:43pm #4

Same issue, although we are on a stranger use case. 

Unity version of the sdk, vuforia 7.1.35 on a Chromebook: the Lenovo Duet. Camera feed runs fine on a different chromebook and on ios, android, and uwp.

AttachmentSize
Image icon Image from iOS (1).jpg822.63 KB

Camera issue : Red and blue colors are switched in camera on Xiaomi Mi9T

August 5, 2020 - 6:02pm #3

I do not load the cameras by code. I only load scenes using code. and those scenes have cameras in them 

ps: sorry for the slow reply 

Camera issue : Red and blue colors are switched in camera on Xiaomi Mi9T

July 30, 2020 - 1:15am #2

Hi,

Are you modifying the cameras via code?

I'm asking as the unloading and loading of the ARCamera should done automatically from Vuforia. I've also tested the behaviour on an Huawei P20 Pro using the Core Sample apps and was not able to reproduce the issue.

Thank you.

Vuforia Engine Support

Log in or register to post comments