Log in or register to post comments

Camera Options with ARCore

July 4, 2018 - 8:21pm #1

Vuforia SDK Version: 7.2.2 -

Description with steps to reproduce: I've updated my project to Vuforia 7.2 and imported the ARCore plugin. The Ground Plane is now working amazing on my Samsung S7 Edge. However, I'm unable to focus the camera properly. Before, I'd have it so if you tapped on the screen, it would focus the cam by using this code:

CameraDevice.Instance.SetFocusMode(CameraDevice.FocusMode.FOCUS_MODE_TRIGGERAUTO);

But now that doesn't do anything. I saw in the Known Issues section - that "ARCore versions 1.0-1.2 do not support continuous auto-focus which may cause issues when detecting small targets or VuMarks". Considering when the app is no longer in focus, any small targets are untrackable. I've tried setting the Vuforia settings to optimize quality but still nothing.

I've noticed that if I enable the ARCore plugin (tried core-1.2.0 and core-1.3.0) then I'm unable to do any camera focusing or enable/disable the torch.When using ARCore, does it completely disable any camera settings we can access?

Enabling ARCore also makes the initial app open/load noticeably longer. -

Development OS (Mac OS X, Windows, Linux): Windows -

Mobile OS and Version: Android 7.0 -

Mobile Device Manufacturer and Model name: Samsung Galaxy S7 Edge -

Do the Vuforia Sample Applications show the same behavior?: Yes

Camera Options with ARCore

July 8, 2018 - 6:14pm #3

Thanks Strazza. 

Seeing that at this stage - enabling ARCore will mean you can't autofocus or access the flashlight/torch. That's fine, just means I can't integrate ARCore yet as it will break the functionality of our app.

Now when I try to upload the app to Google Play, I get this error:

The minimum version code of the ARCore dependency com.google.ar.core.min_apk_version is not in the AndroidManifest.xml file, but the com.google.ar.core metadata tag has been specified.

Only way for Google Play to accept this is to have the core .aar file in the Android plugin folder with Android checked. I've tried having the .aar file in the Android plugins folder but with Android unchecked. I've tried removing it from the project too and I still get the Google Play upload error.

Is there a fix for this?

Camera Options with ARCore

July 5, 2018 - 2:26pm #2

Hello magglemitch,

Unfortunately, ARCore controls the camera focus when being utilized within Vuforia. ARCore does not currently support autofocus and therefor will not function when used within Vuforia. This was similarly the case with ARKit's initial launch and we expect it will be addressed by the ARCore team in the future.

Thanks,

Vuforia Engine Support

Log in or register to post comments