Log in or register to post comments

"Could not find specified video device"

May 5, 2020 - 1:41pm #1

Hello, I've been trying to do a test project on vuforia but unfortunately I've hit a roadblock. the camera simply won't work for me. I'm probably making it harder for not using a proper webcam but instead a dslr. 

I've read other posts and my options were either software like sparkocam and camlink, I ended up giving up then, but last week Canon released their official software to turn the cameras into webcams and I decided to go back to trying it. As it stands the software is in beta, and doesn't work on some other programs like discord, so I don't know if it's the same case here.

I also have obs with the virtual cam plug in that lets me select it in other programs and that's the work around i've found for discord.

In unity however I get and error that says "Could not find specified video device":

ERROR - Could not find specified video device

UnityEngine.WebCamTexture:Play() Vuforia.WebCamTexAdaptor:Play()Vuforia.WebCam:StartCamera()Vuforia.CameraDevice:StartCameraDevice()Vuforia.CameraDevice:Start()Vuforia.VuforiaARController:StartVuforia(Boolean)Vuforia.VuforiaARController:StartAfterInitializationCompleted()Vuforia.VuforiaARController:Start()System.Delegate:DynamicInvoke(Object[])Vuforia.DelegateHelper:InvokeDelegate(Delegate, Object[])Vuforia.DelegateHelper:InvokeWithExceptionHandling(Action)Vuforia.VuforiaBehaviour:Start()

 

I've added a new profile on the xml file already but I can't fine a way around this, I'd like to know if there's any way to make this work or if I'm missing something, thanks.

AttachmentSize
Image icon Capture 2.JPG76.2 KB
Image icon Capture 1.JPG177.7 KB

"Could not find specified video device"

May 6, 2020 - 7:26am #2

Hi,

Unfortunately you followed the recommended steps of adding the camera to the webcamprofile.

The issue might lie with the fact that the system does not recognize it as a webcam.

Have you tried adding the camera directly in the webcamprofile? Where you able to use the DSLR as a webcam without emulating it through OBS? If yes, use the name that appear there for the webcamprofile.

Thank you.

Vuforia Engine Support

Log in or register to post comments