Topic has a solution and is locked
Log in or register to post comments

Database Textures White

December 6, 2016 - 6:41am #1
Topic solved

I have a target database with the following picture included.

When exported to unity and using the ImageTarget to select the database,

the texture is white.

What to do?

AttachmentSize
Image icon F16WBMDIQ6VC5V2.LARGE_.jpg63.68 KB

Database Textures White

June 16, 2017 - 9:58pm #14

Thanks .... its work

Database Textures White

May 23, 2017 - 3:04am #13

Oh thank you dude you saved me.

Database Textures White

April 14, 2017 - 7:24am #12

I solved my porblem!

Thaks you!

 

Database Textures White

February 12, 2017 - 11:57am #11

1 ) Go to Project > Editor > QCAR > ImageTargetTextures > DataBaseName in Project Window Assets Folder.

2) Click on ImageNmae_scaled

3) In inspector window Set :

        3.1) Texture Type to : Default

        3.2) Texture shape to : 2D

See Image

4) Hit Apply

5) Click on ImageTarget in Hierarchy View and in inspector select Database and your Image target

6) You Are Done !

See Image

Database Textures White

December 17, 2016 - 10:16am #10

SuneetM wrote:

I think I've found a temporary fix.

 

Open the folder for your database found in Assets/Editor/QCAR/ImageTargetTextures/

 

Move the files out of that folder onto your desktop (for example) and then drag back in the image files (leaving the metadata files on the desktop. When I did this, it seemed to force Unity to rebuild the metadata files and the image targets are now showing up as normal.

 

Hope that helps.

 

Yo bro it works fine now. it was my first project and it all got messed up . Thanks alot . would love to know if u get to know any permanent fix as this issue is faced by many ppl. do post it if u find one

Database Textures White

December 11, 2016 - 4:16pm #9

The solution of removing the .meta files works, but it would be nice to know if the source of the issue is with the .unitypackage built by Vuforia, or the package importer in Unity.

Database Textures White

December 8, 2016 - 4:59am #8

This worked for me too, many thanks!

Database Textures White

December 7, 2016 - 9:42am #7

Hi! I just read your post, Just wondering is it the same problem as mine? 

Because I've just posted it about just now, but it seems we have the same problem is it?

 

Database Textures White

December 7, 2016 - 9:41am #6

SuneetM wrote:

I think I've found a temporary fix.

 

Open the folder for your database found in Assets/Editor/QCAR/ImageTargetTextures/

 

Move the files out of that folder onto your desktop (for example) and then drag back in the image files (leaving the metadata files on the desktop. When I did this, it seemed to force Unity to rebuild the metadata files and the image targets are now showing up as normal.

 

Hope that helps.

 

Hi SuneetM,

I've tried your solution and it works, it is showing up! Thank you so much! Hope it remains like this till end.

Thanks again friend! Really appreciate it! :)

Database Textures White

December 7, 2016 - 8:05am #5

I think I've found a temporary fix.

 

Open the folder for your database found in Assets/Editor/QCAR/ImageTargetTextures/

 

Move the files out of that folder onto your desktop (for example) and then drag back in the image files (leaving the metadata files on the desktop. When I did this, it seemed to force Unity to rebuild the metadata files and the image targets are now showing up as normal.

 

Hope that helps.

Database Textures White

December 7, 2016 - 8:00am #4

I'm having the same issue myself. I've tried using Unity 5.5.0f3 on Windows 10 as well as macOS Sierra in case it was an OS related problem and the issue replicates. I've also tried importing image target databases from a few weeks back which are 'known good' (i.e. they've showed up with textures before) and they are visible as a white plane.

 

Inspecting the ImageTargetTexture folder for the databases reveal textures icons with black circles. When I run the project in play mode or exported to my android device, the image targets are being recognised which allows me to continue with my project however it makes it really difficult to align virtual buttons on the image target.

Database Textures White

December 7, 2016 - 4:32am #3

Hi shazwina165, I'm not sure if you're asking me or the original poster, but yes, it appears we have the same problem.

I'll also comment below your post so that it is clear that at least two persons have this issue.

Database Textures White

December 7, 2016 - 3:25am #2

I have this issue too, hopefully someone has an answer or can direct us to a thread with the solution.

When I press the play button, I see in the console that the imagetarget is recognized when I present the original to the webcam. The dimensions also change in the scene view when I select another image in the database, but the texture stays white.

Log in or register to post comments