Log in or register to post comments

Difference between iOS and Android

August 2, 2016 - 5:44am #1

Hi all,

 

I made a scene in Unity based on Vuforia. I have used about 15 imagetargets and on approximately 10 I put a Video prefab (from the videoplayback sample)

When I build it for iOS all is working as expected. I see a videoframe with a play button on it and when I press it it plays.

But under Android the behaviour is different. The imagetargets get recognized but more than half of the playbuttons are not playbuttons but the error button (an X) or the loading button (the hourglass). When I press the X or hourglass the video is played in the native player, not on the plane.

All video's are "ripped" from youtube with the same tool and are 320x180 mp4 H.264 files. I have tried converting to m4v or mkv, but the result is the same: iOS is all fine but Android isn't.

Can someone suggest me what can be wrong? Or what I can do to fix it?

 

kind regards,
Eric de Haan

Difference between iOS and Android

February 22, 2017 - 10:04pm #3

Hello EricDeHaan ,My name Jeo John.In my point of view i like android more than ios ,because the android is more user friendly than the ios to me.In the cases of data sharing the android shows more advantages than ios.I have a company based on slideway lubricants .In our company we use the both ios and android devices for several purposes like video conference,data exchanging etc.In the case of video conference the ios shows better quality. Except video conferencing the android device shows more advantages than ios. So i like andriod.Thank you.

Difference between iOS and Android

December 16, 2016 - 1:07am #2

Hi Eric 

I don't have an answer for you but I am planning on doing a similar thing - launching videos with image targets on both iOS and Android. 

 

I'm not able to get my videos to play on iOS I just get an hourglass that never goes away. My video is a small m4v file in the Streaming Assets folder. Can't for the life of me seem to figure it out, do you have any suggestions? I am running the new everything (which might be part of the problem). 

 

MacOS Sierra, just upgraded Unity and downloaded the new Vuforia and Video Playback packages... iPhone 7 running 10.1.1

 

Thanks for any tips!

Log in or register to post comments