Log in or register to post comments

Finding Image Target breaks Stereo View

January 3, 2018 - 5:27am #3

Vuforia SDK Version: 7.0.36 -

Description with steps to reproduce: I am trying to build a VR application in Unity and I need to use the VideoBackground. I have a skybox and an image target in my scene. Now if the camera finds the Image Target in the scene, the object I placed on the target gets rendered correctly in Stereo View. But my background skybox is rendered wrong and I can't focus on the background with my eyes anymore. The two images are not correctly rendered for stereo view anymore.
This problem only happens as long as I see the Image Target in the Gear VR. As soon as I rotate my head and loose the image target the skybox makes a little jump, just like some internal view center or something is resetted, and then the skybox gets rendered correctly again.

So my problem is the combination of the VideoBackground and a skybox. This also happens with a small 3D sphere around my scene. I tried changing World Center Mode, the Mixed Reality Controller, scaling a skybox sphere, but nothing helps. Everytime I get a little spike as soon as the camera finds an image target and then the stereo view gets rendered incorrectly. Loosing the image target means everything gets rendered correctly again.

Any help or just information what in the render process for the Gear VR changes when vuforia finds an image target would be greatly appreciated.
Thanks a lot -

Development OS (Mac OS X, Windows, Linux): Windows -

Mobile OS and Version: Android 7.0 -

Mobile Device Manufacturer and Model name: Samsung GearVR -

Do the Vuforia Sample Applications show the same behavior?:

Finding Image Target breaks Stereo View

January 3, 2018 - 3:29pm #2

Hello till1008,

GearVR has been deprecated beginning with Vuforia 6.5: https://library.vuforia.com/content/vuforia-library/en/articles/Solution/Developing-for-the-Gear-VR.html

Apologies for the inconvenience,

Vuforia Support

Finding Image Target breaks Stereo View

January 4, 2018 - 2:05am #1

Hello Strasza,

thanks for the quick answer. I tried the same steps with Vuforia 6.2 and it too didn't work.

A hint in the Digital Eyewear section in the Vuforia Configuration would be really helpful. I didn't see the deprecated hint in the documentation. And the configuration gives the impression that GearVR is fully supported.

Log in or register to post comments