Topic locked

Flickering GUI buttons in android unity

September 21, 2015 - 8:05am #4

Vuforia SDK Version: 5.05 -
Description with steps to reproduce:


1. Everytime I import Vuforia into a clean project I get 

Assets/Vuforia/Scripts/WireframeBehaviour.cs(41,24): warning CS0618: `UnityEngine.Material.Material(string)' is obsolete: `Creating materials from shader source string will be removed in the future. Use Shader assets instead.'

2. Much larger issue

Building for android 5.1 in unity 5.1.3 (unsure if issue exists in iOS as I havent tried) i get flickering rgb tinted buttons when I have Vuforia enabled. It goes away when I delete the asset. The only way to get rid of them is to enable development mode, which obviously isnt realistic for production versions. I have the asset!/content/14656 which when enabled, I assume also creates a form of debugging, becaue it also removes the issue, but again, i dont want fps counter on my production app, just to fix the issue your software is creating.

On some occasions after restarting unity the issue goes away unless I turn on MultiThreaded Rendering. On my Samsung Tab2 the opposite works and requires the MultiThreaded to be on, otherwise the same issue occurs. So unless I enable dev mode, I cant get it working on both devices properly

I have attached a screenshot that illustrates the issue



Development OS (Mac OS X, Windows, Linux): Windows -
Mobile OS and Version: Android 5.1 -
Mobile Device Manufacturer and Model name: Sony Xperia Z3 -
Do the Vuforia Sample Applications show the same behavior?: Havn't tried

Flickering GUI buttons in android unity

September 21, 2015 - 10:57pm #3

Have tried it on sample scenes and experience the same issue

Flickering GUI buttons in android unity

September 23, 2015 - 9:26pm #2

why am i getting no reply on this? Its a majot issue with your software

Flickering GUI buttons in android unity

September 24, 2015 - 8:57pm #1
Topic locked