Log in or register to post comments

Image Target + Virtual buttons and Object tracking

March 31, 2015 - 8:10am #1

Vuforia SDK Version: 4.0 -

Description with steps to reproduce:

Hello,

 

I have a scene with one Image Target with Virtual Buttons and one Object Tracking.

When I run the scene, I get this error :

<pre class="brush: csharp">
Virtual Button enabled value could not be set.
UnityEngine.Debug:LogError(Object)
Vuforia.VirtualButtonImpl:SetEnabled(Boolean)
Vuforia.VirtualButtonAbstractBehaviour:UpdateEnabled()
Vuforia.VirtualButtonAbstractBehaviour:OnTrackerUpdated(Boolean)
Vuforia.StateManagerImpl:UpdateVirtualButtons(Int32, IntPtr)
Vuforia.QCARManagerImpl:UpdateTrackers(FrameState)
Vuforia.QCARManagerImpl:Update(ScreenOrientation)
Vuforia.QCARAbstractBehaviour:Update()
</pre>
 
This does not happen if I deactivate the data set in QCARBehaviour.
The issue happens even if I do not put the Object Target prefab in the scene and  keep the data set enabled in QCARBehaviour.
 
 
Thanks,
Regards,
Fabien

-

Development OS (Mac OS X, Windows, Linux): Windows -

Mobile OS and Version: iOS8 -

Mobile Device Manufacturer and Model name: Apple iPhone 6 -

Do the Vuforia Sample Applications show the same behavior?: There is no such sample, but it happens with the standard prefabs and the demo datasets.

Image Target + Virtual buttons and Object tracking

April 29, 2015 - 7:58pm #6

It sounds like the problem might be a simple VirtualButton setup issue. Have you compared your project to our VirtualButtons sample app for Unity:

https://developer.vuforia.com/downloads/samples

 

Image Target + Virtual buttons and Object tracking

April 29, 2015 - 2:49am #5

Hello,

I am placing the Virtual Button in the Unity scene beforehand, not in Play Mode nor progammatically.

Thanks,

Image Target + Virtual buttons and Object tracking

April 28, 2015 - 9:29pm #4

Are you placing a Virtual Button prefab in the Unity scene beforehand or are you trying to add a Virtual Button programmatically? If you are trying to add one programmatically using the API, then you need to deactivate the DataSet first.

https://developer.vuforia.com/resources/api/unity/interface_vuforia_1_1_image_target

https://developer.vuforia.com/resources/api/unity/class_vuforia_1_1_object_tracker

 

Image Target + Virtual buttons and Object tracking

April 27, 2015 - 12:39am #3

Hello,

Sorry for the late answer.

  1. No, it's created in the scene,
  2. No, all the DataSet are active when I create the Virtual Button. I tried to delete the VirtualButton, deactivate all the DataSets, create the VirtualButton again and activate the DataSets, but it shows the same error.

 

Regards,

 

Image Target + Virtual buttons and Object tracking

April 6, 2015 - 4:54pm #2

A couple of questions:

  • Are you trying to create a VirtualButton at runtime?
  • Are you deactivating the DataSet before trying to create the VirtualButton?

https://developer.vuforia.com/resources/api/unity/interface_vuforia_1_1_image_target

 

Log in or register to post comments