Log in or register to post comments

Image Targets not accurate anymore

January 14, 2018 - 3:47pm #1

Vuforia SDK Version: 7.0.36 -

Description with steps to reproduce: In updating my app for the arrival of Ground Plane - I've noticed running Unity 2017.3 with an iPhone X that the image trackers aren't as accurate, or something weird is happening. It picks up the image, and the content spawns on top as it is supposed to- but now the sizing/center etc seems off. None of the content matches up perfectly with the target now - and it seems to get worse the further the camera is away from the target. Up close it is still off but not terrible, but moving it away causes it to look like the content is moving away from the target.

I've tried a blank project using just the AR Camera, Image, and a Cube centered on the target and the same thing happens. Just wondering if you're aware of this issue - or it is something I'm doing wrong which hopefully has an easy fix. -

Development OS (Mac OS X, Windows, Linux): Mac OS X -

Mobile OS and Version: iOS 11.1.2 -

Mobile Device Manufacturer and Model name: Apple iPhone X -

Do the Vuforia Sample Applications show the same behavior?: I haven't tested the sample applications, but a blank project and imported in Vuforia's ARCam and ImageTarget (which are all built into Unity now)

Image Targets not accurate anymore

March 21, 2018 - 4:37pm #2

Any idea on how to fix this? It seems to be happening with all ARKit devices. It makes the alignment of the content impossible to get right.

Log in or register to post comments