Log in or register to post comments

Image tracking lag

July 23, 2019 - 4:07pm #1

Vuforia SDK Version: 8.3.8 -
Description with steps to reproduce: Having 'track device pose' set to true cause's tracking lag to the object mapped to the marker. Especially visible while moving around the marker. Augmented object lags behind the movement, even though the camera feed is running smooth. The lag only impacts the augmented content. Issue is resolved if 'track device pose' is turned off. Using Unity 2019.1.0f2. Worked fine when using 8.1.x, issue started after updating to 8.3.8.

– Create new scene
– add ARCamera + image target, add a 3d object to target.
– Track device pose set to true, tracking mode positional.
– Using the app -
Development OS (Mac OS X, Windows, Linux): Mac OS X -
Mobile OS and Version: iOS, all versions -
Mobile Device Manufacturer and Model name: Apple iPhone X -
Do the Vuforia Sample Applications show the same behavior?: Couldn't get samples to run however issue still occurred when creating a new Unity project from scratch.

Image tracking lag

September 10, 2020 - 7:22pm #7

Hi! I'm having the same issue! My project on android is working perfectly but when a change to ios the lag starts or the objects get fixed to the camera.

If I move the phone objects moves like they were not in AR.

Maybe something related to Extended tracker? Something wired.. if I pull down notification center (camera pause) and resume, the tracking improves but for a few seconds

but extended traker "turns off".

I tried a new project with simple set up (camera image and a cube) same result. I tried using opengl 3, metal, Auto.

Vuforia 9.3.3

Xcode 11.x

unity 2019.3.13f1

iPhone 7 ios 12.3

iPhone 7 ios 13.2

iPhone 8 Plus ios 13.2


But, I also tried starting a new project and importing the sample project from Asset Store and that works perfect.

I tried using the same config in my project but no luck. I checked log and both projects show same info:

Metal device with ArKit support ddetected, usign Vuforia fusion. API: Opengl 2.x 

There is something in the sample project diferent? Any config I may missing?

Thank you.

Image tracking lag

August 13, 2019 - 7:31am #6


I've tried to reproduce the issue with the provided image, unfortunately I was *not* able to. Used in my test following config: Vuforia SDK 8.3.8, Astronaut animation from the Vuforia Core Samples, plane surface as background, the provided image as image target and Iphone X as test device.

In order to investigate further we would require following:

1. A copy of your project to further test the behavior ( if you are not comfortable sharing here, please dm me the information)

2. OS version of the device.

Thank you.

Vuforia Engine Support

Image tracking lag

August 13, 2019 - 2:07am #5


Yes we are using the image target, I've attached the image we used below. This bug was happening on all the image targets we were using.

We have tested on printed targets and we got the same issue.


Image icon p2_marker.jpg354.1 KB

Image tracking lag

August 12, 2019 - 10:48am #4


Are you using the Image Targets feature? If so, please share the 2D image file uploaded to the Target Manager. This will allow me to attempt to replicate the setup.

Have you tried testing with a printed target? I'm wondering if rolling shutter is impacting performance.


Vuforia Engine Support

Image tracking lag

August 12, 2019 - 6:42am #3

Thanks for getting back. Have read though those notes and I don't believe they are related.

My project does not have the Metal graphics API enabled, just OpenGLES2 and OpenGLES3. Also the bug is occurring on an iPhone X which uses an A11 chip.

I've attached a video of the behaviour I'm experiencing. To reiterate, this is only happening with Extended tracking enabled. When not enabled, the models sticks rock solid with the similar movement and same marker.

Thanks for your help.

(Just realised that I replied from a different account, I'm still the same person from the OP)



Package icon demo.zip5.26 MB

Image tracking lag

August 5, 2019 - 11:04am #2


Please refer to this this issue to determine if it is impacting you: https://developer.vuforia.com/forum/unity/known-issues-unity-20191


Vuforia Engine Support

Log in or register to post comments