Log in or register to post comments

Init Error and black screen

March 31, 2016 - 8:45pm #1

Vuforia SDK Version: 5.5.9 -

Description with steps to reproduce:

Recorgnizing image target and Showing an object which suppose to be seen WORKS WELL.

But, Sometimes i face a black screen.

And it seems to happen when the vuforia proceeding initalization.

When i debuged it, i got this message.

"INIT_LICENSE_ERROR_INVALID_KEY"

Don't know why i got this message.

i tried to run the app over 50 times. and got this message 3~4 times.

When the error occurs, i  just re-run the app and the license error is gone.

Is that only me who suffering this problem?

-

Development OS (Mac OS X, Windows, Linux): Mac -

Mobile OS and Version: iOS 9.2 / Android 4.4.2 -

Mobile Device Manufacturer and Model name: iPhone6s, Galaxy s4 etc... -

Do the Vuforia Sample Applications show the same behavior?: well, don't know. never tried.

Init Error and black screen

April 20, 2016 - 2:26pm #6

Can you provide a minimal use-case app project (using one of our samples if possible) that reproduces the "invalid key" error? You can provide link in this thread or send via a PM.

Init Error and black screen

April 18, 2016 - 9:44pm #5

Don't know samething happens when use the cloud.

and i use "PlayMaker" and "EveryPlay". i don't use any plugin which affects the camera.

and faced same bug both iOS and Android.

Development OS (Mac OS X, Windows, Linux): Mac - 
Mobile OS and Version: iOS 9.2 / Android 4.4.2 - 
Mobile Device Manufacturer and Model name: iPhone6s, Galaxy s4 etc... - 

 

 

Init Error and black screen

April 18, 2016 - 4:41pm #4

  • Are you using CloudReco in your app?
  • Are you using any 3rd party Unity plugins in addition to Vuforia?
  • Which iOS device are you using?
  • Is problem isolated to iOS or affecting Android as well?

 

Init Error and black screen

April 17, 2016 - 9:04am #3

Yes, i use Unity.

 

And i don't think it has something to do with AR and non-AR scenes.

 

Because i have faced same error both when the app starts with AR scene, and moves to AR scene from non-AR scene.

 

i didn't suspend my app, So i could say that suspending or resuming the app is not my probelm.

Init Error and black screen

April 4, 2016 - 2:18pm #2

  • Are you using Unity?
  • Are you seeing this error when moving between between AR and non-AR scenes?
  • Are you seeing this error when suspending and resuming the app?

 

Log in or register to post comments