Log in or register to post comments

IO9 Unity 5 plugin issue

October 20, 2015 - 1:39pm #7

Vuforia SDK Version: Vuforia SDK v4.2.3 -

Description with steps to reproduce:

Hello,

I would like to submit my app to Itunes connect in order to test some achievements . I migrated the app from Unity 4.6 to Untiy 5.1.2 so far locally everything seems to work fine (scan, coud reco etc.) but i getting this error:

ERROR ITEMS-90512: "Invalid sdk value. The value provided for the sdk portion of LC_VERSION_MIN_MACOSX in myapp.company.com/QCARWrapper.bundle/Contents/MacOS/QCARWrapper is 10.9 which is greater than the maximun alowed value of 9.1".

This happens when i try to upload the ips to Itunes connect. Do i need to update the lib?

 

thanks this is very urgent btw.

-

Development OS (Mac OS X, Windows, Linux): Mac OS X -

Mobile OS and Version: 10.10.5 -

Mobile Device Manufacturer and Model name: ios device -

Do the Vuforia Sample Applications show the same behavior?:

IO9 Unity 5 plugin issue

October 21, 2015 - 12:44am #6

You need to:

  • Select the QCARWrapper.bundle in the Unity Project view (located under Assets > Plugins ), so that its settings are shown in the Unity Inspector
  • Change the settings of QCARWrapper.bundle in the Unity inspector from "Any Platform" to "Standalone + Editor".

 

see also:

https://developer.vuforia.com/forum/unity-3-extension-technical-discussion/vuforia-50-and-unity-5

 

IO9 Unity 5 plugin issue

October 21, 2015 - 12:45am #5

... and then rebuild your App for iOS.

IO9 Unity 5 plugin issue

November 24, 2015 - 5:43am #4

Hi,

I'm working on a Windows machine and use UnityCloudBuild to create an IPA right now. When I then try to upload the IPA via Application Loaded App on a Mac I get these errors (see screenshot). I did what you wrote above and set the Platform to "Standalone" and "Editor". I still get the error. Maybe CloudBuild doesn't use/get these settings?

Any idea what to do next?

Note: I upgraded from vuforia 5.0.5 to 5.0.6 during development. Maybe I did something wrong?

Thanks

AttachmentSize
Image icon 2015-11-24_apple-errors-edit.jpg203.21 KB

IO9 Unity 5 plugin issue

November 24, 2015 - 9:54am #3

@railon:

I think you are facing a different issue;  you need to build a project targeting iOS directly on Mac (as the PostProcessBuildPlayer script will adjust the generated Xcode project) 

 

IO9 Unity 5 plugin issue

November 25, 2015 - 3:32am #2

@AlessandroB,

it was my mistake. I changed the setting on the QCARWrapper.dll instead of the QCARWrapper.bundle folder! Now it worked and I could submit the App via Application Loader to iTunesConnect. ;-)

I've attached two screenshots showing what I changed for other people hitting this issue (or myself) in the future. Would it be possible that you change this setting in the next version of vuforia? Or did I just break something with the settings I use?

Thanks

IO9 Unity 5 plugin issue

November 25, 2015 - 7:33am #1

Oh, that's great to hear ! ;-)

 

Would it be possible that you change this setting in the next version of vuforia? Or did I just break something with the settings I use?

 

We are considering the possibility of setting the DLLs and Bundles to "Editor" up-front in the future, but we also need to take into account backward compatibility w.r.t Unity 4.x, as those settings for DLLs and Bundles have been introduced in Unity 5, while they did not exist in Unity 4.x

Log in or register to post comments