Log in or register to post comments

[iOS] Lib crashes with non-ASCII chars in the PRODUCT_NAME

July 1, 2013 - 2:31am #1

Vuforia SDK Version: 2.5.7 -

Description with steps to reproduce:

With a PRODUCT_NAME that contains non ASCII characters (like áâà) the library crashes when loading the data sets. Traces of a failed execution:

2013-07-01 11:19:28.254 â[4274:907] ARParentVC: creating

2013-07-01 11:19:28.265 â[4274:907] ARParentVC: loading

2013-07-01 11:19:28.269 â[4274:907] ARVC: loadView

2013-07-01 11:19:28.440 â[4274:907] QCAR OpenGL flag: 2

2013-07-01 11:19:28.456 â[4274:907] ARVC: viewDidLoad

2013-07-01 11:19:28.529 â[4274:907] QCARutils onCreate()

2013-07-01 11:19:28.534 â[4274:907] APPSTATUS_INIT_APP

2013-07-01 11:19:28.541 â[4274:907] APPSTATUS_INIT_QCAR

2013-07-01 11:19:28.548 â[4274:907] ARVC: Rotating to Portrait

2013-07-01 11:19:28.580 â[4274:907] ARParentVC: appearing

2013-07-01 11:19:28.585 â[4274:907] ARVC: Rotating to Portrait

2013-07-01 11:19:28.588 â[4274:907] ARVC: viewWillAppear

2013-07-01 11:19:28.651 â[4274:907] ARVC: Rotating to Portrait

2013-07-01 11:19:28.681 â[4274:907] EAGLView: layoutSubviews

2013-07-01 11:19:28.722 â[4274:4f03] INFO/AR(4274) 2013-07-01 11:19:28: QCAR SDK version 2.5.7

2013-07-01 11:19:29.177 â[4274:907] ARParentVC: appeared

2013-07-01 11:19:29.179 â[4274:907] ARVC: viewDidAppear

2013-07-01 11:19:29.180 â[4274:907] QCARutils onResume()

2013-07-01 11:19:29.315 â[4274:907] ***** No audio tracks in asset *****

2013-07-01 11:19:34.097 â[4274:907] APPSTATUS_INIT_TRACKER

2013-07-01 11:19:34.149 â[4274:907] Successfully initialized ImageTracker.

2013-07-01 11:19:34.150 â[4274:907] APPSTATUS_INIT_APP_AR

2013-07-01 11:19:34.152 â[4274:907] APPSTATUS_LOAD_TRACKER

2013-07-01 11:19:34.156 â[4274:4f0b] INFO/AR(4274) 2013-07-01 11:19:34: ImageTracker: Successfully created dataset

### App crashed ###

------------------------------------------------------------------------------------------------

Steps to reproduce:

1. Take one of the sample appications and change the PRODUCT_NAME, add a non-ASCII chars to it. Some chars to copy them: áàâäñç

2. Execute the app

------------------------------------------------------------------------------------------------

Workaround:
Use a PRODUCT_NAME with ASCII chars and change the CFBundleDisplayName with the correct name.

 

 

-

Development OS (Mac OS X, Windows, Linux): Mac OS X -

Mobile OS and Version: iOS 6.1.4 and iOS 7.0 beta2 -

Mobile Device Manufacturer and Model name: Apple iPhone -

Do the Vuforia Sample Applications show the same behavior?: Yes, when the PRODUCT_NAME is modified (i.e. add á to the product_name).

[iOS] Lib crashes with non-ASCII chars in the PRODUCT_NAME

July 10, 2013 - 7:30am #3

Just to clarify that this feature will not be supported.

thank you

 

N

[iOS] Lib crashes with non-ASCII chars in the PRODUCT_NAME

July 1, 2013 - 6:40am #2

Thanks for reporting.

I will revert back when we have more info.

 

N

 

Log in or register to post comments