Log in or register to post comments

Ipad Autorotation Issue

September 30, 2015 - 5:11pm #1

Vuforia SDK Version: 5.0.5 -

Description with steps to reproduce:

Issue Replicated using Vuforia's Sample Apps

Testing Harness

using CloudReco 5.0.5 Vuforia Sample
change target to IOS
change from portrait to auto-rotation
using XCode 7.0
tested using following Unity Versions. Unity 5.1, Unity 5.2 and Unity 5.2.1 (made no difference)
Target Device #1: Ipad Air 16GB Running IOS 9.0.1 (also tested IOS 9.0.0)
Target Device #2: Ipad 3 16GB Running IOS 9.0.1 (also tested IOS 9.0.0)

To Replicate

Launch app in Portrait Mode
Rotate to Landscape
Rotate back to Portrait
Camera Feed is Reversed (Inverted?)

Launch app in Landscape Mode
Rotate to Portrait
Rotate back to Landscape
Camera Feed is Reversed (Inverted?)

Sometimes the Camera feed is Reversed (Inverted) as soon as it opens.

Also tested (below models are all working fine using auto-rotate option)

Galaxy S3
Galaxy S6 edge
Nexus 4
Iphone 5s - (using IOS Version 9.0.0 and IOS Version 9.0.1)
Nexus 10

Seems like this is an issue affecting only Apple Ipads.

Could we get some feedback on how to fix this issue? Thank you

-

Development OS (Mac OS X, Windows, Linux): Mac OS X, Unity3D -

Mobile OS and Version: 9.0.0 and 9.0.1 -

Mobile Device Manufacturer and Model name: Ipad Air, Ipad 3 -

Do the Vuforia Sample Applications show the same behavior?: Yes, Tested using CloudReco 5.0.5 Vuforia Sample in Autorotation

Ipad Autorotation Issue

June 2, 2016 - 10:55pm #14

Hi, 

 

I want to support rotation for iOS App. Right now , though the camera rotates but the view is upside down. pleas help.

Ipad Autorotation Issue

October 9, 2015 - 7:07am #13

We filed the issue to Unity, using the non-Vuforia reproducible steps described by dm3d (issue reproducible in Unity 5.2.1)

 

 

Ipad Autorotation Issue

October 8, 2015 - 6:36pm #12

The workaround provided by dm3D works great developer.vuforia.com/forum/issues-and-bugs/ipad-autorotation-issue#comment-2058909 . 

Thank you for vuforia's feedback and also thank you onefatsheep's post caught the attention to generate the solution.

 But the orientation error comes back once during our testing. Still trying to recreate the steps.

 

Ipad Autorotation Issue

October 8, 2015 - 4:48pm #11

Note that the iOS 9 iPad orientation issue is not a Vuforia issue. The bug can be easily reproduced in a non-Vuforia Unity 5.2.1f1 project. I tested this using an iPad Air 2 (9.0.2). Here's the steps:

1. Create empty Unity 5.2.1f1 project
2. Add new text element using UI -> Text
3. Name the text object "Orientation"
4. Create C# script and name it "DisplayOrientation"
5. Attach the script to a new empty GameObject
6. Open the script and replace contents with the following:

using UnityEngine;
using System.Collections;

using UnityEngine.UI;

public class DisplayOrientation : MonoBehaviour
{

	ScreenOrientation screenOrientation;
	
	Text orientation;

	// Use this for initialization
	void Start()
	{
		screenOrientation = Screen.orientation;
		orientation = GameObject.Find("Orientation").GetComponent<Text>();
		orientation.text = "Orientation: " + Screen.orientation.ToString();
	}
	
	// Update is called once per frame
	void Update()
	{
		if (screenOrientation != Screen.orientation) {
			orientation.text = "Orientation: " + Screen.orientation.ToString();
			screenOrientation = Screen.orientation;
		}
	}
}

7. Verify that Unity iOS Player settings have Auto Rotation and all 4 orientations selected
8. Build your project
9. If running built project from Xcode, also make sure all 4 orientations are selected in Build Settings
10. First time rotation Portrait -> LandscapeLeft is okay, but after this, rotations are incorrectly reported by Unity
11. Reminder: These are the steps to reproduce the orientation bug using iOS 9 iPad and Unity 5.2.1f1.
12. For the current workaround to avoid bug, see this post farther down in this thread:

Workaround: https://developer.vuforia.com/forum/issues-and-bugs/ipad-autorotation-issue#comment-2058909

 

Ipad Autorotation Issue

October 8, 2015 - 12:24am #10

The issue is not observed in Unity 5.1.x, so it appears to be a specific regression of version 5.2.x with  specific iOS 9 iPad models (e.g. iPad Air, but not on iPad 4 or iPad mini 1st generation)

 

On Unity 5.2, 

have you tried the steps previously suggested by dm3d, i.e. by enabling Autorotation in Unity Player Settings while disabling the "Upside Down" orientation in the Xcode project settings.

Ipad Autorotation Issue

October 7, 2015 - 10:19am #9

Same issue here.

Test with Unity 5.2.1p2 (autorotation), Xcode 7.0.1, iPad air iOS 9.0.2. Use the Vuforia sample apps. The camera flipped when rotate the apps.

 

I reported the issue in another post https://developer.vuforia.com/forum/unity-extension-technical-discussion/unity-52-xcode-7-ios-9-vuforia-505-camera-orientation-pro but I was dispointed with their reply:

Note: the Video Playback sample, as provided, is designed to work in Portrait Mode, not landscape or autorotation (for that, you'll need to customize the sample code). On an iPhone 5S with iOS 9, the sample works correctly when launched in Portrait mode.

My work around as follow:

Unity build setting :portrait

Add the following code to the starting scene to allow auto rotation (Non AR): 

	void Start() {
		StartCoroutine( setOrientation() );
	}

	public static IEnumerator setOrientation()
	{
		Screen.orientation = ScreenOrientation.AutoRotation;
		Screen.autorotateToPortrait = true;
		Screen.autorotateToPortraitUpsideDown = true;
		Screen.autorotateToLandscapeLeft = true;
		Screen.autorotateToLandscapeRight = true;
		
		yield return new WaitForEndOfFrame ();
		yield return new WaitForEndOfFrame ();

	}

Add the following code to the AR scene to fix the rotation to portrait: 

 

void Start() {
		StartCoroutine( setOrientation() );
	}

	public static IEnumerator setOrientation()
	{
		Screen.orientation = ScreenOrientation.Portrait;
		Screen.autorotateToPortrait = true;
		Screen.autorotateToPortraitUpsideDown = false;
		Screen.autorotateToLandscapeLeft = false;
		Screen.autorotateToLandscapeRight = false;
		
		yield return new WaitForEndOfFrame ();
		yield return new WaitForEndOfFrame ();
		
	}

so only the AR scenes is fixed to protrait and the rest of the scenes are set to auto rotation. 

 

But this is only a work around. I seriously hope Vuforia could help to fix this problem. After all, I am a paid developer with numbers of licenses just want a little help.

Ipad Autorotation Issue

October 6, 2015 - 1:54pm #8

  • Which specific version of Unity 5.1.x are you using when testing on your iPad Air (9.0.2) device?
  • Could you try building your project with Unity 5.1.2f1 and running on iPad Air (9.0.2)?

 

Ipad Autorotation Issue

October 4, 2015 - 11:34pm #7

Have you also tested in Xcode 7.0.1 ? (you mention Xcode 7.0 in your first post);  here we've tried on Unity 5.2.1p2 (latest patch release) and Xcode 7.0.1.

https://unity3d.com/unity/qa/patch-releases

 

Ipad Autorotation Issue

October 4, 2015 - 7:27pm #6

We have tested on our end using the below test suite and here are the follows (for future readers)

The landscape issue is still there (on sample app and our apps). Performing the following changes fixes the problem.

- Upgrading to IOS 9.0.2

- Disable "Upside Down" Option in XCode. 

The issue is still there on 9.0.2 if "Upside Down" is enabled in XCode.

Thank you for the help!

Ipad Autorotation Issue

October 4, 2015 - 4:02pm #5

Excellent thank you!

Will test on our end and report back.

Ipad Autorotation Issue

October 2, 2015 - 12:11pm #4

In the iOS 9.0.2 release notes (  https://support.apple.com/kb/DL1842?locale=en_US  ), the following bug fix is mentioned:

  • Fixes an issue where the screen could incorrectly rotate when receiving notifications

 

which suggests there was an issue with iOS 9.0 and 9.0.1 with screen rotation handling, now fixed in 9.0.2.

 

An initial test on a few iPad models seems to indicate that the autorotate issue with Vuforia camera disappears by upgrading the device to iOS 9.0.2.

 

 

Ipad Autorotation Issue

October 2, 2015 - 5:09am #3

You may also want to upgrade your device to the latest iOS 9.0.2 that was released today. 

Ipad Autorotation Issue

October 1, 2015 - 4:51pm #2

Try this:

  1. Enable all 4 orientations in Unity settings
  2. Build project for iOS and open in Xcode
  3. Disable "Upside Down" orientation in Xcode
  4. Compile and run on iPad

 

AttachmentSize
Image icon ios9_unity_autorotation.png39.37 KB
Log in or register to post comments