Log in or register to post comments

new Engine 8.6.7

December 13, 2019 - 12:14am #1

Vuforia SDK Version: 8.5.9 -

Description with steps to reproduce: Unity 2019..2.15.f1
I made a project with 8.5.9: ok
I saw a popup asking me to download the new version, what I did.
Compile error:
uses-sdk:minSdkVersion 16 cannot be smaller than version 19 declared in library [:VuforiaWrapper:]
Suggestion: use a compatible library with a minSdk of at most 16,
or increase this project's minSdk version to at least 19,
or use tools:overrideLibrary="com.vuforia.engine.app" to force usage (may lead to runtime failures)

Under Preferences > External Tools,, automatic installs of Android NDK, JDK and SDK are ticked.

I took a copy of my project.
I did not download the new engine when prompted.
==> Build Ok -

Development OS (Mac OS X, Windows, Linux): Windows 10 -

Mobile OS and Version: Not applicable -

Mobile Device Manufacturer and Model name: Not applicable -

Do the Vuforia Sample Applications show the same behavior?: Don't know...

new Engine 8.6.7

December 15, 2019 - 8:49am #2

From the 8.6.7 release notes:

On Android, the minimum SDK version is now specified for the native Vuforia plugin. This prevents Unity from adding additional permissions to the Android Manifest that are not actually required by Vuforia Engine. The minimum supported version is 19 (Android 4.4 KitKat).

 

So you need to set the Minimum API Level in player settings to Android 4.4 or higher

Log in or register to post comments