Log in or register to post comments

No 'git' executable was found

January 14, 2021 - 3:03pm #1

Vuforia SDK Version: 9-6-4 -

Description with steps to reproduce: Hi there,

Today i tried to instill for the fist time Unity and Vufora but i had problem doring it:

"
An error occurred while resolving packages:
Project has invalid dependencies:
com.ptc.vuforia.engine: No 'git' executable was found. Please install Git on your system then restart Unity and Unity Hub

A re-import of the project may be required to fix the issue or a manual modification of C:/Users/alegr/OneDrive/Documenti/Unity/test/Packages/manifest.json file.
"

But in the jason file i have that already worte:
"com.ptc.vuforia.engine": "git+https://git-packages.developer.vuforia.com#9.6.4",

What should i do? i sow few forum speaking about this problem, but them solution didn't work for me

-

Development OS (Mac OS X, Windows, Linux): Windows -

Mobile OS and Version: Windows 10 -

Mobile Device Manufacturer and Model name: Dell Precison 7530 -

Do the Vuforia Sample Applications show the same behavior?: Yes

No 'git' executable was found

February 19, 2021 - 1:34pm #8

Thank you so much. I have been struggling with this for the past 2 days. 

No 'git' executable was found

February 18, 2021 - 3:53pm #7

I had this same problem. My solution was this:



Hit windows key and type in cmd then hit enter. 

Type in git

If a git help menu comes up you have it installed, and just need to add C:\Program Files\Git\cmd to your system path. 

If it does not come up you need to install git and make sure that path is there. Reboot and it worked for me.

Note: Make sure you are in your WINDOWS CMD and not another other cmd

No 'git' executable was found

February 16, 2021 - 5:32am #6

Hi  i am ralph and i will teach you how to fix this kind of problem.

Now first i need to explain it to you why we have a problem.

An error occurred while resolving packages:

  Project has invalid dependencies:

    xxxx: No'git' executable was found.

Please install Git on your system and restart Unity

As you can see the system could not find the right path or a git software to install necessary libraries.

First step install a software called Fork Git it has a trial version but it will be enough to cover entire fixing duration.

 

after the installation, find the path same as this into your system.

C: \ Users \ [username] \ AppData \ Local \ Fork \ gitInstance \ 2.24.1 \ cmd

Now copy it and go to your System/ System and Security / Advance and find the Environment Variables button.

Now goto PATH Variables and add a new path. Remember this ? C: \ Users \ [username] \ AppData \ Local \ Fork \ gitInstance \ 2.24.1 \ cmd

add it and find the same Path below and follow the other path.

Then reopen the Unity software and open your system and its done.

 

Email me so that i can teach you.

ralph.sinsuat@gmail.com

No 'git' executable was found

February 16, 2021 - 12:36am #5

Hi,

Unfortunately I was not able to reproduce this, I've tested with 2019.4.11/ 2020.2.4/ 2020.2.2.

Please try the 3 option: Download Vuforia Engine SDK and Import Manually mentioned in this article: https://library.vuforia.com/articles/Solution/vuforia-engine-package-hosting-for-unity.html

Thank you.

Vuforia Engine Support

EDIT: As a workaround when receiving the error, please try installing GIT, restart the pc and delete the Library folder from the project.

No 'git' executable was found

February 8, 2021 - 1:03pm #4

mismo problema !! alguien que pueda ayudar ??? unit no dice nada y vuforia menos !! que mal por estas dos empresas que no pueden resolver el problema

No 'git' executable was found

January 19, 2021 - 12:18am #3

Same problem, same message !

Try to install Git on my mac but nothing change.

But old project vuforia with old version of vuforia still working

No 'git' executable was found

January 15, 2021 - 6:43am #2

Same problem here!

I've tried it in Unity versions:

2020.1.0a15 and 2020.2.1f1

I've instaled clear 2020.2.1f1 today hoping to do a quick tutorial, but after loading add-vuforia-package-9-6-4.unitypackage nothing changes in tools and following prompt appears:

An error occurred while resolving packages:

  Project has invalid dependencies:

    com.ptc.vuforia.engine: No 'git' executable was found. Please install Git on your system then restart Unity and Unity Hub

A re-import of the project may be required to fix the issue or a manual modification of H:/XXXXXX/XXXX/XXXXXXX/New Unity Project/Packages/manifest.json file.

when I try to load it again "nothing to import!" prompt appears.

 

Log in or register to post comments