Log in or register to post comments

No shadows on build

March 13, 2017 - 2:16am #5

Vuforia SDK Version: 6.2 -

Description with steps to reproduce: Not sure if this is a bug or if I've done something wrong.

I have shadows showing up in Unity scene view and when I run it through the webcam. But once I build it out to my iPhone I'm not getting any shadows.

Any ideas?
Thanks.... -

Development OS (Mac OS X, Windows, Linux): Unity5.5 on Windows, Build in XCode 8 -

Mobile OS and Version: iOS 10.2 -

Mobile Device Manufacturer and Model name: Apple iPhone 6 Plus -

Do the Vuforia Sample Applications show the same behavior?: not sure....haven't built them out to my device as yet.

No shadows on build

March 18, 2017 - 6:02am #4

Any ideas anyone?

are there meant to be shadows in the build or do they only work in Play back?

Cheers

No shadows on build

March 22, 2017 - 11:00am #3

Same Question  / issue

Shadows render in Unity Scene Preview through the webcam but don't  render when built out to iPhone 

Development OS (Mac OS X, 10.11.6): Unity5.5.2 Build in Xcode 8.2.1) Previewed on iPhone 5 iOS 9.3.5

No shadows on build

May 18, 2018 - 4:53pm #2

Check your quality settings, by default, when your project target iOS, the quality settings will be Medium for iOS, you should override this by settings for example the settings to ultra or modifying the medium layer to allow shadows...

No shadows on build

January 21, 2021 - 10:20am #1

Thank you so much AAKLebanon. I have been struggling for ages to get those shadows to work in my builds. Setting the quality in Project Settings to a higher level finally made them appear.

Log in or register to post comments