Log in or register to post comments

Problem with AR view in landscape on 32 bit iOS devices

September 18, 2015 - 9:35am #1

Vuforia SDK Version: 4.2.3 -

Description with steps to reproduce:

We found out that in our application on iPads with 32 bit architecture there is a problem with AR view in landscape mode and we have difficulties finding the reason and the solution. 

There are 2 problems. When we are in landscape mode there are always tiny black triangles across the view.  

The other problem is that when we are very close to the marker the rendered image get's "ripped". It never occurs in portrait mode on 32 bit iOS devices, and it never occurs in portrait and landscape modes on 64 bit iOS devices. 

We've reproduced this on iPad 2, iPad 3 and iPad 4 with different iOS versions but always iOS 8+ 

-

Development OS (Mac OS X, Windows, Linux): Mac OS X -

Mobile OS and Version: iOS8 -

Mobile Device Manufacturer and Model name: Apple iPad -

Do the Vuforia Sample Applications show the same behavior?:

Problem with AR view in landscape on 32 bit iOS devices

September 21, 2015 - 2:42am #3

Hi,

Thanks for the near and far planes suggestion, we'll check that.

We have tried with 5 release (it didn't help) but not yet with 5.0.5 which we will do today. 

I'm also attaching screenshots of the problem. 

Thanks

AttachmentSize
Image icon rip2.jpg1.65 MB
Image icon rip.jpg1.71 MB
Image icon triangles.jpg559.77 KB

Problem with AR view in landscape on 32 bit iOS devices

September 18, 2015 - 11:35am #2

Hi,

Have you tried with out latest release 5.0.5?

Can you send some screenshots showing the ripped image? Is it the augmentation or the video background?

If it is the augmentation being clipped have you checked your near and far planes?

Log in or register to post comments