Log in or register to post comments

Problem with extended tracking on HoloLens 2

July 23, 2020 - 12:50pm #1

Vuforia SDK Version: 9.2.8 -

Description with steps to reproduce: I'm developing a simple app to track a multi-target and display a holographic cube on the HoloLens 2. If I do not use Vuforia, I can visualize the cube through the HoloLens 2 and it is very stable. When I use Vuforia, it will track the target fairly well and display the cube. When the tracker is lost and extending tracking takes over, the cube is noticeably less stable and exhibits a good amount of swim, particularly when head movement is anything other than very slow.

Configuration:
Unity 2019.2.21
Vuforia 9.2.8

Steps to reproduce:
Configure space for mixed reality, i.e. set main camera to 0, 0, 0, clear flags to solid black, add XR in player settings and enable Vuforia, 16 bit depth, single pass instancing, enable depth buffer, set to very low quality, switch build platform to UWP
Add Vuforia behavior script to main camera
Enable "Load Object Targets On Detection"
Enable "Track Device Pose"
Add Multi-target and set position to 0, 0, 0.2
Select "consider target as visible if its status is 'tracked or extended tracked' "
Create 3D object - cube and set as child to Multi-target
Set 3D object position to 0, 0, 0.5

Build and deploy via VisualStudio2019

-

Development OS (Mac OS X, Windows, Linux): Windows -

Mobile OS and Version: UWP -

Mobile Device Manufacturer and Model name: Microsoft HoloLens 2 -

Do the Vuforia Sample Applications show the same behavior?: I have not tried the sample, but my implementation above is very basic and the initial tracking works as intended. It is the extended tracking that has issues.

Problem with extended tracking on HoloLens 2

March 9, 2021 - 7:31am #3

Hi,

is there any update on this? I'm struggling with the same issue (Hololens 2, MRTK 2.5, Vuforia 9.6.4)

Problem with extended tracking on HoloLens 2

October 20, 2020 - 8:00am #2

I've got a very similar issue on the Hololens2, the sample with vuforia demonstration works properly but when i create my own app, the 3D model that appears on an image target is unstable and move with the headset but in the opposite direction (for example : when i turn my head right, the model goes left).

I'm totally stuck, and have been worked on the problem for few days now

Log in or register to post comments