Log in or register to post comments

Samsung Galaxy tab 3

June 17, 2015 - 9:31am #1

Vuforia SDK Version: vuforia-unity-mobile-android-ios-4-2-3 -

Description with steps to reproduce:

I have tested a couple of apps in a Samsung Galaxy tab 3

Only display de splash screen butn nothing more happens

I have donde target recognition and video playback

In other devices works perfeclty fine

 

Hope you have a solution for this bug

Thanks in advance

-

Development OS (Mac OS X, Windows, Linux): Andorid -

Mobile OS and Version: Android 4.0 -

Mobile Device Manufacturer and Model name: Smasung GT-P5210 -

Do the Vuforia Sample Applications show the same behavior?: Yes

Samsung Galaxy tab 3

August 5, 2015 - 11:31am #25

The Galaxy Tab 3 (GT-P5210) has the Intel Atom Z2560 CPU and works fine with the ARMv7 setting. Can you try running an ARMv7 compiled project that doesn't include Vuforia and see if it works?

 

Samsung Galaxy tab 3

July 31, 2015 - 9:42am #24

My Samsung Tab 3 have a Intel Atom CPU, maybe that´s the cause why it crashes using the ARMv7

and it works with the x86

but in x86 the camera is black

 

Any sugestions??

Thanks in advance

 

Samsung Galaxy tab 3

July 31, 2015 - 8:29am #23
This is what its in the logcat
 
07-31 10:23:34.117: D/houdini(15786): [15786] Loading library(version: 4.0.2.44380 RELEASE)... successfully.
07-31 10:23:34.147: D/dalvikvm(15786): Trying to load lib /mnt/asec/com.Elements.Tst-4/lib/libmain.so 0x438948e0
07-31 10:23:34.147: D/dalvikvm(15786): Added shared lib /mnt/asec/com.Elements.Tst-4/lib/libmain.so 0x438948e0
07-31 10:23:34.157: I/Unity(15786): splash_mode = 0 (integer)
07-31 10:23:34.157: I/Unity(15786): hide_status_bar = True (bool)
07-31 10:23:34.157: I/Unity(15786): useObb = False (bool)
07-31 10:23:34.167: A/libc(15786): Fatal signal 11 (SIGSEGV) at 0x00000000 (code=1), thread 15786 (om.Elements.Tst)
 
hoope you can help me
Thanks

Samsung Galaxy tab 3

July 30, 2015 - 11:10pm #22

Use the ARMv7 setting and then get the error stack from the logs when the app crashes on the device.

Samsung Galaxy tab 3

July 30, 2015 - 9:54pm #21

When I use de AR mv7 device setting it crashes the app

I have to change to x86 or FAT  it shows the screens but then the camera is black

 

What can I do??

Samsung Galaxy tab 3

July 30, 2015 - 9:02pm #20

Attached is a screenshot of the Android Player Settings used in Unity 5.1.1f1 with ImageTargets 4.2.3 sample.

AttachmentSize
Image icon unity511f1_android_settings.png70.36 KB

Samsung Galaxy tab 3

July 30, 2015 - 8:10pm #19

Please could you send a print screen of your Adroid player settings

I`ve triied so many times and all of them the camera is black

Sure I´m doing something wrong

 

Thanks in advance

 

Samsung Galaxy tab 3

July 30, 2015 - 5:06pm #18

bgg1206 wrote:

Do I need to buy a licenese to tst the Vuforia SDK??

And why in the other Android devices it works, but in the Samsung Galaxy tab 3 doesn´t??

You don't need to buy a license. I'm testing with a Starter key and the ImageTargets 4.2.3 sample with Unity 5.1.1f1 works fine on a Galaxy Tab 3 (GT-P5210) with Android 4.4.2.

 

Samsung Galaxy tab 3

July 30, 2015 - 1:31pm #17

I have a Starter license, and tryed again with another license key but the camera is still black

 

Do I need to buy a licenese to tst the Vuforia SDK??

 

And why in the other Android devices it works, but in the Samsung Galaxy tab 3 doesn´t??

 

Samsung Galaxy tab 3

July 30, 2015 - 11:21am #16

Just figured this mystery out...

 

My Bronze accout was suspended yesturday. (Image atatached).

I created a starter licence, repaced the licence key in the project and the camera worked! - The project added an overlay somthing like "Powered by Vuforia."

Just re-purchased the Bronze licence, lets see what that does.

Hope this all helps

 

https://developer.vuforia.com/targetmanager/licenseManager/licenseListing

 

 

AttachmentSize
Image icon GC_Vuforia_LicenceManager.JPG19.62 KB

Samsung Galaxy tab 3

July 30, 2015 - 10:35am #15

Yes, plus the Licence Key

I also just tried running with the new OS Lollipop 5.0.1 on the Note 4 - Same issue

Samsung Galaxy tab 3

July 30, 2015 - 10:26am #14

 ImageTargets-5-0-5.unitypackage with only 3 Edits to install:

    -   Company Name

    -   Product Name

    -   Bundle Identifier

...and the License Key pasted into your ARCamera, I guess...

Samsung Galaxy tab 3

July 30, 2015 - 10:21am #13

I have the same exact issue.Still all Black screen.

 

ImageTargets-5-0-5.unitypackage

Vuforia SDK 5.0 in Unity 5.11 with Samsung Tab 4 Android KitKat 4.4.4

 

Fresh install: ImageTargets-5-0-5.unitypackage with only 3 Edits to install:

    -   Company Name

    -   Product Name

    -   Bundle Identifier

All defaults.. 

    -   the Automatic Graphics API checkbox is disabled (unchecked)

    -   the Graphics API list only includes OpenGL ES 2.0 (and NOT  OpenGL ES 3.0)

    -   Multihreaded Rendering both on or off

    -   Point still nothing

I am upgrading to Lolipop Just saw there is an Tab 4 update available from Tmobile, I'll keep you posted.

Let us know if you get anything to work.

Samsung Galaxy tab 3

July 30, 2015 - 9:25am #12

Hi I´ve tested with the Vuforia SDK relase 5.0.

in Unity 5.1.1

And in the Samsung Tab 3 still the camera is black

Both rear and front, I´ve changed with teh settings but nothing happens

In the other devices work perfect

 

Thanks and hope can find a solution

 

Samsung Galaxy tab 3

July 30, 2015 - 7:12am #11

Hi bgg1206,

you mentioned in one of your previous post that you also tried upgrading to Unity 5.0 and 5.1.

 

Two questions:

- what version of Unity 5.1 ? (5.1.0, 5.1.1 or 5.1.2)

- have you checked your Graphics API settings under Android Player Settings ? Here you need to make sure that:

    -   the Automatic Graphics API checkbox is disabled (unchecked)

    -   the Graphics API list only includes OpenGL ES 2.0 (and NOT  OpenGL ES 3.0)

could you verify that ?

 

Additionally, you may want to consider trying the new Vuforia SDK relase 5.0.

https://developer.vuforia.com/downloads/sdk

https://developer.vuforia.com/downloads/samples

https://developer.vuforia.com/library/articles/Solution/Vuforia-5-Migration

https://developer.vuforia.com/library/articles/Solution/Migrating-Unity-Projects-to-Vuforia-5

Samsung Galaxy tab 3

July 30, 2015 - 5:33am #10

Thnaks, but the camera still is in black

Any other suggestion??

 

Samsung Galaxy tab 3

July 30, 2015 - 2:38am #9

Try Multithreaded Rendering in playersettings, worked for me.

Samsung Galaxy tab 3

July 28, 2015 - 11:48am #8

The model number is: GT-P5210

And nothing appears en screen, it´s all black

Samsung Galaxy tab 3

July 27, 2015 - 8:29pm #7

  • If you point the device to a printed target (stones or chips), do you see the teapot augmentation being tracked (using ImageTargets 4.2.3 sample), even if the video background is black?
  • What is the exact model number of your Galaxy Tab 3?

 

Samsung Galaxy tab 3

July 15, 2015 - 8:35am #6

I´ve updated the Samsung tab 3 to Android 4.4

And using the Unity 5.0 and 5.1 tested the Imgage tracking example and didn´t work

After the instructions screen the camer went to black

 

In another devices with Android like an Sonyh smartphone with Android 4.3 the same app works perfect

 

Please help me to find what is the problem with teh Samsung tab

 

Thanks in advance

 

Samsung Galaxy tab 3

July 14, 2015 - 9:04am #5

Hi, I´ve tested the ImageTargets 4.2.3 Unity sample and doesn´t work

it stops at the Quualcom Vuforia screen

 

I´m using Unity 4.5

And the Samsung tablet has Android 2.2.2

 

Maybe the problem is the Android version??

 

I tested with the Vuforia 2.6.7 and it works perfect in the same tablet

 

Thanks in advance

Samsung Galaxy tab 3

July 2, 2015 - 8:45pm #4

I tested a Samsung Galaxy Tab 3 (GT-P5210) with Android 4.4.2 with ImageTargets 4.2.3 Unity sample and it worked okay.

Do you have OpenGL ES 2.0 selected in the Android Player Settings?

What version of Unity are you using?

 

Samsung Galaxy tab 3

June 24, 2015 - 7:53pm #3

it´s ARMv7 device filter, it´s teh only option available

Samsung Galaxy tab 3

June 23, 2015 - 7:45pm #2

The Samsung GT-P5210 Galaxy Tab 3 spec shows that it has an Intel Atom processor. What Device Filter setting do you have in Unity's Android settings?

 

 

Log in or register to post comments