Log in or register to post comments

[Solved] Red tinted camera

November 30, 2019 - 2:37pm #1

Vuforia SDK Version: Unity 2019.2.14 -

Description with steps to reproduce: In Unity 2019.2.14 with Vuforia, when we add an ARCamera object to the scene the view is tinted in red. Here's a screenshot of the app with the red camera view, including Vuforia logo: https://pasteboard.co/IJ8VVyp.png This happened after updating from an older Unity / Vuforia setup (2018.2.21). Before the upgrade the image was ok. When played directly on Unity it doesn't show the red color in the camera. We have: - reviewed all objects (camera, canvas, ...) for possible reasons. - tried different settings of graphics API. - searched for similar issues in the forums. we found some other effects in the camera view but they didn't seem to be the same. - if we draw some text / other 3d models on top of an image marker they are correctly displayed. Has anyone else seen this? Any idea what can be the cause? Thanks! -

Development OS (Mac OS X, Windows, Linux): Mac OS X & Windows -

Mobile OS and Version: Android 10 / 9 -

Mobile Device Manufacturer and Model name: Google Pixel 4, Google Pixel 2XL, Samsung S8 -

Do the Vuforia Sample Applications show the same behavior?:

[Solved] Red tinted camera

November 13, 2020 - 5:01am #5

go to Vuforia Ar Camera-->Open Vuforia Engine Config-->Video Background--> Change it to none ("Custom/VideoBackground") 

[Solved] Red tinted camera

August 8, 2020 - 6:57pm #4

Have the same issue. In editor all work well. But on device have same red tinted view and no tracking

[Solved] Red tinted camera

January 22, 2020 - 7:03am #3

delete the past vuforia folder


[Solved] Red tinted camera

December 1, 2019 - 8:51am #2

Hi again!

We found the issue was caused by the extra Vuforia folder in our project, which was the one we included in the previous version.

After removing that folder the camera started to work ok.


Log in or register to post comments