Log in or register to post comments

Stuck in Unity Splash Screen

April 29, 2015 - 8:03pm #1

Vuforia SDK Version: 3 -

Description with steps to reproduce:

Hello,

I need help. What seems to be the problem? I use unity and tried it on android and it run without a problem. But when I build for xcode and then run it on ipad and iphone it crashes or stuck on Unity splash screen.

 

Please help. Someone told me to paste this on the thread also. Thank you. 

TuscaniaAR`QCARUnityPlayer::QCARInit:

    0xe69d6c <+0>:   push   {r4, r7, lr}

    0xe69d6e <+2>:   movs   r0, #0x8

    0xe69d70 <+4>:   add    r7, sp, #0x4

    0xe69d72 <+6>:   mov    r4, r1

    0xe69d74 <+8>:   blx    0x13a4c60                 ; operator new(unsigned long) at MemoryManager.cpp:167

    0xe69d78 <+12>:  movw   r1, #0x8606

    0xe69d7c <+16>:  movs   r3, #0x0

    0xe69d7e <+18>:  movt   r1, #0xe3

    0xe69d82 <+22>:  add    r1, pc

    0xe69d84 <+24>:  ldr    r1, [r1]

    0xe69d86 <+26>:  add.w  r2, r1, #0x8

    0xe69d8a <+30>:  strd   r2, r3, [r0]

    0xe69d8e <+34>:  bl     0xe6ad84                  ; setPlatform(Platform*) at Platform.cpp:43

    0xe69d92 <+38>:  movw   r1, #0x8759

    0xe69d96 <+42>:  mov    r0, r4

    0xe69d98 <+44>:  movt   r1, #0xc8

    0xe69d9c <+48>:  add    r1, pc

    0xe69d9e <+50>:  blx    0x1aec358                 ; symbol stub for: strcmp

    0xe69da2 <+54>:  cmp    r0, #0x0

    0xe69da4 <+56>:  beq    0xe69dd6                  ; <+106> at QCARUnityPlayer.cpp:169

    0xe69da6 <+58>:  movw   r1, #0x87b2

    0xe69daa <+62>:  mov    r0, r4

    0xe69dac <+64>:  movt   r1, #0xc8

    0xe69db0 <+68>:  add    r1, pc

    0xe69db2 <+70>:  blx    0x1aec358                 ; symbol stub for: strcmp

    0xe69db6 <+74>:  cmp    r0, #0x0

    0xe69db8 <+76>:  beq    0xe69dda                  ; <+110> at QCARUnityPlayer.cpp:169

    0xe69dba <+78>:  movw   r1, #0x8750

    0xe69dbe <+82>:  mov    r0, r4

    0xe69dc0 <+84>:  movt   r1, #0xc8

    0xe69dc4 <+88>:  add    r1, pc

    0xe69dc6 <+90>:  blx    0x1aec358                 ; symbol stub for: strcmp

    0xe69dca <+94>:  mov    r1, r0

    0xe69dcc <+96>:  movs   r0, #0x2

    0xe69dce <+98>:  cmp    r1, #0x0

    0xe69dd0 <+100>: it     eq

    0xe69dd2 <+102>: moveq  r0, #0x12

    0xe69dd4 <+104>: b      0xe69ddc                  ; <+112> at QCARUnityPlayer.cpp:80

    0xe69dd6 <+106>: movs   r0, #0x6

    0xe69dd8 <+108>: b      0xe69ddc                  ; <+112> at QCARUnityPlayer.cpp:80

    0xe69dda <+110>: movs   r0, #0xa

    0xe69ddc <+112>: bl     0xe85868                  ; QCAR::setInitParameters(int)

    0xe69de0 <+116>: bl     0xe6b078                  ; initApplication at QCARWrapper.cpp:60

    0xe69de4 <+120>: bl     0xe85c90                  ; QCAR::init()

    0xe69de8 <+124>: cmp    r0, #0x64

    0xe69dea <+126>: blo    0xe69de4                  ; <+120> at QCARUnityPlayer.cpp:87

    0xe69dec <+128>: cmp    r0, #0x64

    0xe69dee <+130>: it     eq

    0xe69df0 <+132>: popeq  {r4, r7, pc}

    0xe69df2 <+134>: pop.w  {r4, r7, lr}

    0xe69df6 <+138>: b.w    0xe6b068                  ; setInitializationErrorCode at QCARWrapper.cpp:55

-

Development OS (Mac OS X, Windows, Linux): Mac OS X -

Mobile OS and Version: 7.1 -

Mobile Device Manufacturer and Model name: Apple -

Do the Vuforia Sample Applications show the same behavior?: No

Stuck in Unity Splash Screen

May 5, 2015 - 11:32pm #3

Thank you good Sir. Now I have used the new version of Vuforia and Unity. I have now a new problem which is this on the attached picture. It used to have no problems at all with the 3d objects. Can someone help? It makes the wall and other objects blink, some meshes are out of place and the over brightness from the light even though I have tried to adjust the directional light. Thank you.

AttachmentSize
Binary Data bytes
Image icon Screen Shot 2015-05-06 at 2.35.38 PM.png1.03 MB

Stuck in Unity Splash Screen

May 4, 2015 - 3:24am #2

Current version of Vuforia is 4.0.105

you are welcome to upgrade to this version, which supports Unity 4.6, Unity 5.0, Android, iOS 7 and iOS 8 and Xcode 6.

See also:

https://developer.vuforia.com/library/articles/Solution/How-To-Migrate-a-Unity-Project

 

Log in or register to post comments