Log in or register to post comments

Troubleshot Shadow

August 10, 2016 - 7:38pm #1

Hello All..

Does anyone found solution from this problem?


I have been searching for whole week and i can't find the solutions.

please let me know if there is way to clear this problem shadow in vuforia and how you do it.

oh, and i have try with vuforia 6 and there's no change.


Thank's a Lot :D

Troubleshot Shadow

February 9, 2019 - 4:09am #9

Thanks for sharing. How do you get this to work using Ground Plane? (and a transparent plane)

Troubleshot Shadow

April 4, 2018 - 10:59am #8

Hello ,

You Can show this video to How Create Shadow with Vuforia 



Shadow Vuforia wth unity

Troubleshot Shadow

August 15, 2016 - 7:57pm #7

Thank you dpizzle it works!!!!!

I just change the quality setting and change the setting for the shadow and then VIOLA!!!!.. the shadow still appear when i move the camera away..

I really appreciate your answer and your time to answer my question..

one more time.. Thank You Dpizzle.. :)




Troubleshot Shadow

August 15, 2016 - 7:30am #6

Read the docs here: http://docs.unity3d.com/Manual/class-QualitySettings.html

Green check mark represents current quality per platform.  Select simple and change the shadow setting or set android to a higher a quality level.



Troubleshot Shadow

August 14, 2016 - 11:38pm #5

Thank you for your replay dpizzle :)

Yeah, i talk about the shadow dissapearing when camera move away in some distance from image target, my models still in there but the shadow doesn't, but if my camera close form image target the shadow appear..

Here my seeting quality form m project:

 i try to change the shadow distance too.. but there is no change..

do you have any idea??

Troubleshot Shadow

August 13, 2016 - 6:28am #4

You're talking about the shadow disappearing when you move the camera away?  I don't think this is Vuforia related.  Look at your shadow distance in the quality settings.

Edit-> Project Settings-> Quality.    Always best to keep your markers and models in reasonable game units,  this way Unity's defualt shadow settings usually work well.  


Troubleshot Shadow

August 11, 2016 - 7:29pm #3

Thank for the reply :)


1. I have been using Unity 5.3.6

2. For rendering path i using Rendering Path: Forward

3. Light shadow type i using Soft shadow and i have been try change to hard shadow too but there's no difference

4. Here my values for cliping plane:


Is there problem with my setting??


Troubleshot Shadow

August 11, 2016 - 3:33pm #2

If using Unity:

  • Which version of Unity?
  • What setting for Rendering Path?
  • What light Shadow Type?
  • What Clipping Plane values for Camera?

Log in or register to post comments