Log in or register to post comments

The type name 'ModelRecoSearchResult' does not exist in the type 'TargetFinder'

August 7, 2019 - 1:03am #1

Vuforia SDK Version: 8.3.8 -

Description with steps to reproduce: I updated vuforia 8.3.8 but giving me a warning update to 8.3.9. when i open package manager seems 8.3.9 and update is inactive. I think there is a problem and there is a very much important problem. I have this error

Library/PackageCache/com.ptc.vuforia.engine@8.3.9/Vuforia/Scripts/DefaultModelRecoEventHandler.cs(266,71): error CS0426: The type name 'ModelRecoSearchResult' does not exist in the type 'TargetFinder'

How can I fix it? -

Development OS (Mac OS X, Windows, Linux): Mac Os -

Mobile OS and Version: Android, IOS -

Mobile Device Manufacturer and Model name: Samsung -

Do the Vuforia Sample Applications show the same behavior?:

The type name 'ModelRecoSearchResult' does not exist in the type 'TargetFinder'

September 26, 2019 - 4:03am #4

Hi @Ayush12397

From which version did you migrate? I'm asking as it is important how you installed Vuforia via "normal" installation or via PackageManager.

Also this error could occur as there is mismatch between the Vuforia Core samples apps and Vuforia SDK.

Some fixes might include:

1. Removing/installing the vuforia sdk via PackageManager

2. Deleting and re-importing the Vuforia Core Samples assets.

Please give it a try.

Thank you.

Vuforia Engine Support

If the above fail, please respond to the first 2 questions.

The type name 'ModelRecoSearchResult' does not exist in the type 'TargetFinder'

September 25, 2019 - 4:50am #3

Hey I am also having the same issue I just updated my old project to unity 2019.2.6f1  and I am facing the error i.e.The type name 'ModelRecoSearchResult' does not exist in the type 'TargetFinder'. Can you please give a solution to fix this. 

The type name 'ModelRecoSearchResult' does not exist in the type 'TargetFinder'

August 7, 2019 - 3:13am #2

Hi,

We posted a link about this issue with 8.3.9, to sum it up, due to a Packet Manager issue, the 8.3.8 version was listed incorrectly as 8.3.9.

https://developer.vuforia.com/forum/unity/known-issue-package-manager-upgrade-engine-839-incorrect

The error you are receiving typically is regarding the mismatch between the Vuforia Core Samples and the Vuforia Engine Version. Please create a new project and try to download the Vuforia Core Samples again.

Thank you.

Vuforia Engine Support

 

Log in or register to post comments