Topic locked

Unable to import Vuforia 9.6.4 to Unity

December 22, 2020 - 12:25pm #13

Vuforia SDK Version: 9.6.4 -

Description with steps to reproduce: Vuforia 9.4 worked just fine for me, and I faced no issue installing it into Unity 2019 and Unity 2020. But, after lots of efforts, I am unable to install/import Vuforia 9.6 into Unity. It shows 'Resolving Packages' and runs infinitely. It happens in both Unity 2019 and Unity 2020. Now, I'm unable to use Vuforia at all. Please solve this issue and try to provide older versions of Vuforia as well. -

Development OS (Mac OS X, Windows, Linux): Windows 10 -

Mobile OS and Version: iPhoneX -

Mobile Device Manufacturer and Model name: iPhone -

Do the Vuforia Sample Applications show the same behavior?:

Unable to import Vuforia 9.6.4 to Unity

December 29, 2020 - 10:08am #12

I face the same problem. Unity recommends me to update Vuforia Engine 9.6.4 from Git all the time. But if I press Update it crashes (resolving packages for infinite), and I see in Task Manager that app is not responding. I have already lost my project because of this because I just can't open it...

Unable to import Vuforia 9.6.4 to Unity

January 5, 2021 - 5:52am #11

Hi @AnastasiiaM @shahdeep,

I can confirm that it is not stuck. Unfortunately we also experienced sometimes a bigger download time then expected. This is related mainly to the move to Git.

In summary it takes longer than expected to download the package and you will see the resolving packages prompt until it finishes.

As an alternative please go over this other available options mentioned here: https://library.vuforia.com/articles/Solution/vuforia-engine-package-hosting-for-unity.html

Thank you for your understanding.

Vuforia Engine Support

 

Unable to import Vuforia 9.6.4 to Unity

January 6, 2021 - 6:56pm #10

I am facing this problem as well.  Importing 9.6 prompts me to upgrade and when I do I end up with a console full of errors.

 

An error occurred while resolving packages:

  Project has invalid dependencies:

    com.ptc.vuforia.engine: No 'git' executable was found. Please install Git on your system then restart Unity and Unity Hub

A re-import of the project may be required to fix the issue or a manual modification of C:/Unity/AROne/Packages/manifest.json file.

 

Git is installed on my system...

Unable to import Vuforia 9.6.4 to Unity

January 7, 2021 - 1:32am #9

Hi @Casanis,

Could you please confirm the Unity version on which you get this error?

Please note that the recommended version for VE 9.6 is 2019.4 LTS+

Thank you.

Vuforia Engine Support

Unable to import Vuforia 9.6.4 to Unity

January 10, 2021 - 6:47am #8

Same problem here. Any news?

Unable to import Vuforia 9.6.4 to Unity

January 12, 2021 - 2:30am #7

Hi @Kamery,

Could you please let me know how did you try to update Vuforia? using the scriptor through Unity or by manually downloading it from our website?

Also please mention the Unity version.

Thank you.

Vuforia Engine Support

Unable to import Vuforia 9.6.4 to Unity

January 20, 2021 - 4:42pm #6

I am also experiencing the same issue. I did not have problems with it until today.

 

Unity 2019.4.15 and Unity 2020.1.14

Vuforia 9.4.6

I tried both importing the package then running the script and also downloading the package directly through git with Package Manager URL.

 

It took 30 minutes to finish resolving packages, and if I try to build then I am hit with the same errors the other people have reported.

Unable to import Vuforia 9.6.4 to Unity

January 21, 2021 - 4:24am #5

Hi @j1wan,

Based on your info, I understand that you where able to install the SDK but it fails when you try to build.

Could you please let me know the error that you got? and for what platform did you try to build?

Thank you.

Vuforia Engine Support

Unable to import Vuforia 9.6.4 to Unity

January 22, 2021 - 7:02am #4

I got the similar issue.

I tried to add vuforia via "add custom package" before, it didn't work because i did not have GIT.

I've installed GIT and it worked once, now I'm creating a new clean project on two machines and I get:

An error occurred while resolving packages:

  Project has invalid dependencies:

    com.ptc.vuforia.engine: Error when executing git command. fetch-pack: unexpected disconnect while reading sideband packet

    fatal: early EOF

    fatal: index-pack failed



A re-import of the project may be required to fix the issue or a manual modification of H:/XXXX/XXXX/XXXXXXXXXXXXX/TEST/Packages/manifest.json file.

Now I'm desperate to make it work for tomorrow morning.

Unable to import Vuforia 9.6.4 to Unity

January 24, 2021 - 11:00am #3

Hi, I have the same problem as shown on the pic. 

Git is installed.

Did anyone of those who have the same problem an answer already which you can share?

AttachmentSize
Image icon import.png124.5 KB

Unable to import Vuforia 9.6.4 to Unity

January 25, 2021 - 1:42am #2

Hi @Konfi,

The error is related to GIT not being in the path and cannot be used to retrieve the package.

There are 2 options to address this issue:

1. Add git to the path environment variable

2. Fownload the package as explained in the last section of https://library.vuforia.com/articles/Solution/vuforia-engine-package-hosting-for-unity.html (Download Vuforia Engine SDK and Import Manually)

Hope this helps.

Vuforia Engine Support

Unable to import Vuforia 9.6.4 to Unity

January 31, 2021 - 7:10am #1

Here is the solution for everyone, watch the video on how to fix the error: https://www.youtube.com/watch?v=l1cVPLVRLSw

Topic locked