Log in or register to post comments

Unity App Freezing on Hololens when Changing Scenes

January 24, 2018 - 12:16pm #1

I've spend the past two days trying to figure this out so I'm hoping someone on here can help or point me in the right direction

 

Here's a little background of some info that might be important:

I have a Hololens app built using Unity 2017.2.0f3. The project was originally created in Unity 5.6 with Vuforia 6.2. I updated Unity and then followed the Vuforia Migration guide to switch to 6.5.

 

Here's the issue I'm having:

When I run the application for the first time after deploying it to the Hololens it runs as expected and I can change scenes to my hearts content. However, once I close out of the app (use bloom to return to the main screen and then remove the app window I was running from the screen) and reopen it, the app freezes when I try and change scenes and I am unable to bloom to the main screen so I have to use the power button to recover.

 

I've used the debugger in Visual Studio when this freeze occurs and it doesn't throw and exceptions or errors. Has anyone seen or heard of this issue or anything similar? I have a feeling it's an issue from the migration to vuforia 6.5 but I'm not 100% sure

Unity App Freezing on Hololens when Changing Scenes

February 1, 2018 - 8:46am #3

Yeah, thats exactly what we are experiencing. We tried upgrading the project again to Unity 2017.2.0p3 after they fixed an issue with "hololens randomly freezing", but this problem persists which makes us believe it's a Hololens-Vuforia issue. We were able to mitigate the problem by moving everything into one scene and reworking how the project runs but that was less than ideal. I agree with you though, Vuforia and Hololens development seems few and far between so this is probably pretty low on their list of priorities for bug fixes.

Unity App Freezing on Hololens when Changing Scenes

January 31, 2018 - 3:18am #2

I've got the exact same behaviour with same parameters: First steps of the project began using Unity 5.6 and now working on Unity 2017.2.0f3 (most recent version where the HoloLens works correctly with Unity...).

No bloom is possible, no exception thrown. Last message is "StartVuforia" and no Update()-Loop of Unity runs anymore.

 

Concerning upgrading Vuforia, though, we kicked everything and implemented it again when changing the Unity version. So just looking at Vuforia, we should have a clean project.

 

Seems that there are very few developers out there using Vuforia and HoloLens :P

Log in or register to post comments