Log in or register to post comments

Unity Smart terrain material not being applied

July 14, 2015 - 5:55pm #1

Vuforia SDK Version: 4.2 -

Description with steps to reproduce:

When running the penguin app on my computer to test smart terrain the ground ice material is not fully used. Instead it uses one solid color from the texture, most likely one of the corners. So instead of seeing ice appear I see a blue transparent plane. This happens on both the computer when running from Unity as well as a deployed application.

-

Development OS (Mac OS X, Windows, Linux): Windows -

Mobile OS and Version: iOS/ Android -

Mobile Device Manufacturer and Model name: Apple iPhone/ Google Android -

Do the Vuforia Sample Applications show the same behavior?: Yes. The problem described happens in the penguin example app

Unity Smart terrain material not being applied

July 22, 2015 - 2:15pm #9

After testing the Penguin app again I did see that it was working, must have been due to the recent upgrade to 5.1.1. However when I moved the shaders into my project and applied the DynamicMeshTexture to my terrain material it doesn't seem to work. Both with and without the shader the terrain renders the same as the screenshot I had posted earlier. I've attached screenshots of the scene with and without the DynamicMeshTexture. Is there something I'm missing in applying this?

AttachmentSize
Image icon With shader applied537.24 KB
Image icon without shader applied1.21 MB

Unity Smart terrain material not being applied

July 22, 2015 - 10:30am #8

I tested the Penguin 4.2.3 sample in Unity 5.1.1f1 and the shaders look okay (see screenshot). I am using a Logitech Webcam.

 

AttachmentSize
Image icon unity511_penguin423.png159.54 KB

Unity Smart terrain material not being applied

July 22, 2015 - 9:25am #7

My bad, yes I do. I got confused with the version of Vuforia, which is 4.2.3.

Unity Smart terrain material not being applied

July 22, 2015 - 9:10am #6

ScottWood wrote:

Unity version 4.1.1

Unity 4.1.x is over 2 years old. Do you mean Unity 5.1.1?

http://unity3d.com/get-unity/download/archive

 

Unity Smart terrain material not being applied

July 21, 2015 - 10:25pm #5

Unity version 4.1.1

Using Windows 7.1

Webcam is PS3Eye, however other teammates have tried with other webcams and compiled APK's with the same result

Using Peguin sample app 4.2.3, same problem exists in another project using smart terrain

No none of the shaders have errors. The other project I tried this in does the same without any of the shaders

Unity Smart terrain material not being applied

July 21, 2015 - 7:05pm #4

  • What version of Unity are you using?
  • Which version of Windows OS?
  • What webcam make/model?
  • Which version of Penguin sample app?
  • Do any of the 3 shaders have errors in the Inspector? [Assets/PenguinAssets/Shader/*.shader]

Unity Smart terrain material not being applied

July 21, 2015 - 3:03pm #3

I have just attached two pictures. The first is a screenshot of the app and what is happening. The second is the testure being applied to the Primary Surface in the smart terrain. 

AttachmentSize
Image icon matissue.png390.03 KB
Image icon Terrain01.png861.64 KB

Unity Smart terrain material not being applied

July 21, 2015 - 11:19am #2

Can you post a screenshot of what you're seeing in Unity?

Log in or register to post comments