Log in or register to post comments

Unity Vuforia OBB app issue after upload to Google Play Market

January 2, 2020 - 2:09pm #1

Vuforia SDK Version: 8.3.8 -

Description with steps to reproduce: I would really appreciate any help or suggestions where to look cause I'm a bit lost after a few days of googling this.

I've made an app with three scenes in Unity with Vuforia (language selection, introduction, AR marker recognition). I had to use obb file to separate the content due to Google Play Market limitations.

When I'm choosing "build and run" in Unity to export project, it installs it on my device and it works fine I can see content and Vuforia loads correctly, everything works fine.

When I've uploaded exactly the same version to Google Play Market and got listed, I've tried to install my app on the same device, but after installing it, now it is missing the fonts on the first scene (looks like they are not loaded correctly). Fonts appear to be fine on the second scene, and then on the third scene Fonts are ok but Vuforia is not loading and I get the black screen.

One thing that I thought may have caused the font issue is that I'm pointing to obb only in the second scene, could that be the case? I have no idea why Vuforia is not loading though.

Also, I'm not sure how to bug fix this as it works perfectly fine when I'm installing it directly to a device from Unity and fails only when it gets installed through Play Market.

I will appreciate any help on this. Thanks in advance. -

Development OS (Mac OS X, Windows, Linux): Mac OS X -

Mobile OS and Version: Android, 6.0 -

Mobile Device Manufacturer and Model name: Samsung Tablet SM-T700 -

Do the Vuforia Sample Applications show the same behavior?: Haven't tried.

Log in or register to post comments