Log in or register to post comments

Unity3D 4.2.2 + Vuforia 2.6 = Not Working

November 7, 2013 - 2:42pm #1

Vuforia SDK Version: Unity3D SDK 2.6 -

Description with steps to reproduce:

http://forum.unity3d.com/threads/192347-Did-Unity-4-2-break-the-current-vuforia-unity-package

Vuforia is completely unable to track any images due to the below error message.

I get the following error when trying to use 2.6 with Unity3D 4.2.2

I have tried downgrading XCODE from 5.0 to 4.6 but no luck, I tried loading up an old project that had a version of Vuforia from 6 months ago and it worked fine.

I have created a new project and reinstalled everything with no luck what so ever.

 

cameraDeviceInitCamera

2013-11-07 17:31:07.885 artest[1148:907] DEBUG/AR(1148) UIView has CAEAGLLayer class

2013-11-07 17:31:07.886 artest[1148:907] DEBUG/AR(1148) UIView does not respond to selector renderFrameQCAR

2013-11-07 17:31:07.887 artest[1148:907] DEBUG/AR(1148) UIView has CAEAGLLayer class

2013-11-07 17:31:07.888 artest[1148:907] DEBUG/AR(1148) UIView does not respond to selector renderFrameQCAR

2013-11-07 17:31:07.889 artest[1148:907] DEBUG/AR(1148) Could not find a UIView with CAEAGLLayer layer class that responds to selector renderFrameQCAR

cameraDeviceGetVideoMode

2013-11-07 17:31:07.899 artest[1148:907] DEBUG/AR(1148) UIView has CAEAGLLayer class

2013-11-07 17:31:07.900 artest[1148:907] DEBUG/AR(1148) UIView does not respond to selector renderFrameQCAR

2013-11-07 17:31:07.901 artest[1148:907] DEBUG/AR(1148) UIView has CAEAGLLayer class

2013-11-07 17:31:07.902 artest[1148:907] DEBUG/AR(1148) UIView does not respond to selector renderFrameQCAR

2013-11-07 17:31:07.903 artest[1148:907] DEBUG/AR(1148) Could not find a UIView with CAEAGLLayer layer class that responds to selector renderFrameQCAR

cameraDeviceSelectVideoMode

2013-11-07 17:31:07.907 artest[1148:907] DEBUG/AR(1148) UIView has CAEAGLLayer class

2013-11-07 17:31:07.908 artest[1148:907] DEBUG/AR(1148) UIView does not respond to selector renderFrameQCAR

2013-11-07 17:31:07.909 artest[1148:907] DEBUG/AR(1148) UIView has CAEAGLLayer class

2013-11-07 17:31:07.910 artest[1148:907] DEBUG/AR(1148) UIView does not respond to selector renderFrameQCAR

2013-11-07 17:31:07.910 artest[1148:907] DEBUG/AR(1148) Could not find a UIView with CAEAGLLayer layer class that responds to selector renderFrameQCAR

Best regards,

Stephan Tanguay

 

 

 

-

Development OS (Mac OS X, Windows, Linux): OS X -

Mobile OS and Version: ios 6 -

Mobile Device Manufacturer and Model name: Apple iPad3 -

Do the Vuforia Sample Applications show the same behavior?: Simple demo with new 2.6 is not working

Unity3D 4.2.2 + Vuforia 2.6 = Not Working

November 11, 2013 - 3:15am #9

No problem, glad it is working for you now.

N

Unity3D 4.2.2 + Vuforia 2.6 = Not Working

November 8, 2013 - 8:34am #8

The problem is I forgot to click the activate check box in the data set load behavior.  Sorry for the confusion, it was a careless mistake on my part.  Thanks for all the help.

Stephan

Unity3D 4.2.2 + Vuforia 2.6 = Not Working

November 8, 2013 - 8:29am #7

The version of Unity should make no difference here.

Unity 4.2.2 should work with the latest version of Vuforia no problem, otherwise you may have something fundamentally wrong in your setup.

Try running the samples that come out of the box.  If they work then chances are you may have old remnants of differnt versions of Vuforia that could be conflicting.

As for the error messages, these are harmless.

 

N

Unity3D 4.2.2 + Vuforia 2.6 = Not Working

November 8, 2013 - 7:57am #6

What would really help would be the ability to download prior versions of Vuforia, I can't find my old downloads and will try extracting an older version from my pervious project.  It would be great if it was possible to download older versions of Vuforia to help resolve issues like this.  Thanks again for looking into this issue. Best regards,

Stephan

Unity3D 4.2.2 + Vuforia 2.6 = Not Working

November 8, 2013 - 7:55am #5

I have moved the project over to another machine and I have the same issue.  I also have an older project from six months ago that compiles no problem.

Machine 1 : OSX 10.8.4 / ( tried xcode 4.6 & 5 ) Unity 4.2.2

- Project with older version of Vuforia compliles no problem

- Vuforia 2.6 compiles but AR is never triggered and the errors mentioned below occur ( trackables are new )

Machine 2 : OSX 10.7.5 / Xcode 4.6.3 / Unity 4.2.2. 

- Project with older version of Vuforia compliles no problem

- Vuforia 2.6 compiles but AR is never triggered and the errors mentioned below occur ( trackables are new )

 

 

 

Unity3D 4.2.2 + Vuforia 2.6 = Not Working

November 8, 2013 - 7:10am #4

What version of OSX / XCODE did you test with?

Unity3D 4.2.2 + Vuforia 2.6 = Not Working

November 8, 2013 - 7:09am #3

The trackables were created yesterday so I don't think the trackables are corrupted, I have already recreated them several times to verify that's not the issue.  I also tried XCODE 4.6 and 5.  If you look at the link I provided for the Unity Forums you can see other people are having Unity 4.2.2 + Vuforia 2.6 issues.

Unity3D 4.2.2 + Vuforia 2.6 = Not Working

November 8, 2013 - 12:09am #2

Hi Stephan,

the problem might be with the dataset; is it a dataset created recently ?

If the dataset was created using the Target Manager prior to the release of Vuforia 2.6, that might be the culprit.

I don't thinkg the Unity version has something to do with this, as we tested 2.6 on Unity 4.2.2 without issues

 

Log in or register to post comments