Log in or register to post comments

VideoPlaybackBehaviour can't play video

October 26, 2016 - 11:02pm #1

Vuforia SDK Version: 6.0.117 -

Description with steps to reproduce: Sorry for my bad english:
1. I import a mp4 format video into assets folder
2. Drag and drop the video into StreamingAssets folder
3. Apply the quality form 0.5 to 1 of video
4. Error message displayed on console:
"MissingReferenceException: The object of type 'MovieImporter' has been destroyed but you are still trying to access it.
Your script should either check if it is null or you should not destroy the object."
5. The video can't played in the ios and android application while application was exported successfully.
6. Other video can played normally as imported before.

Other Situation (same error still occur):
1. I tried to updated latest Unity version and reboot computer serveral times.
2. I tried to open a new project to import video into StreamingAssets folder.
3. I tried to press "Reimport all", the full project can't played video normally.
4. I tried to use Windows 7 to import assets.
5. I tired to copy a GameObject to played video which are imported before and played normally,
but new GameObject can't played video normally, old GameObject still function normally,
same error message displayed "MissingReferenceException: The object of type 'GameObject' has been destroyed.

Platform:
Uniy Plus Subscrible, Unity 5.4.2f1, Mac OS Sierra, Vuforia SDK 6.0.117

Latest Update:
The Unity engineer told me we do not need to import the video info Assets folder, just put it info StreamingAssets and press "Reimport", so no need to import video via "Editor".
Next, i do it, The video plane still can't play video normally, nothing to show. Please help us. -

Development OS (Mac OS X, Windows, Linux): Mac OS X -

Mobile OS and Version: ANDROID IOS -

Mobile Device Manufacturer and Model name: APPLE SAMSUNG -

Do the Vuforia Sample Applications show the same behavior?:

VideoPlaybackBehaviour can't play video

June 25, 2018 - 1:49am #3

 fix can't play video on vuforia 

AttachmentSize
Image icon screen shot.png865.56 KB

VideoPlaybackBehaviour can't play video

June 25, 2018 - 1:41am #2

same

Log in or register to post comments