Log in or register to post comments

Vuforia 4.0 Messed up overlay UI

March 3, 2015 - 7:58am #1

Vuforia SDK Version: 4.0 Release -

Description with steps to reproduce:

We have recently migrated to the recently released Vuforia 4.0 Unity plugin and are currently experiencing an issue when using the cloud reco component.  So I’m  just reaching out to see if you may be able to help us or possible point us in the right direction?

 

Our application currently use both the local and cloud scanning component in the same scene.  This allows us to offer offline scanning (local device database) with the ability to add cloud based markers without needing to update the app.  The application had a UI overlay on top of the scanning camera (using NGUI).

 

This all worked great in Vuforia 3 and the beta version of Vuforia 4; however, once we migrated to the release version of 4.0 we suddenly noticed that all of the overlay UI elements are suddenly displayed as black square textures.  The interesting thing is that if we disable the cloud component, suddenly everything is good (all overlay UI elements look correct).  It’s almost as if the cloud component camera scanner is corrupting the display overlay textures or something?

 

We removed all Vuforia components from the project and re-imported it again, just to ensure a clean install with no luck.

 

I was wondering if you have seen this or heard of any other reports similar to this?  Is there anything specific ‘camera’ elements that we may be able to tweak?  I noticed that when the cloud scanning mode is active a small “white scan line” scrolls across the screen.  Is this something that could be cause our graphical issues or something that we could turn off as a test?

 

Thanks and any help would be greatly appreciated.

-

Development OS (Mac OS X, Windows, Linux): Mac OSX -

Mobile OS and Version: 8.0 -

Mobile Device Manufacturer and Model name: iPhone -

Do the Vuforia Sample Applications show the same behavior?:

Vuforia 4.0 Messed up overlay UI

May 4, 2015 - 5:06am #8

You can try the latest Vuforia 4.0.105, as this issue may be resolved in that version.

Vuforia 4.0 Messed up overlay UI

March 26, 2015 - 2:45pm #7

We are also seeing a similar issue with the new Unity UI. I submitted a separate bug for it.

Vuforia 4.0 Messed up overlay UI

March 3, 2015 - 1:07pm #6

Thank you for providing these additional details. We are investigating.

Vuforia 4.0 Messed up overlay UI

March 3, 2015 - 12:44pm #5

Hi,

1. Unity Version = 4.6.3  (we were also using 4.6.2 and noticed this issue)

2. iOS device = iPhone 5S, iPhone 4S, iPad 2, iPad 3

3. iOS version = 7 and 8  .. We also see this issue on Android 4.4.2

4. We only see this on the iOS and Android devices.

5. NGUI version 3.7.8

 

I've attached 2 screenshots.. one showing what it looks like on the device (when cloud reco and local reco are enabled) and what it should look like (when cloud reco is disabled and only local device reco is enabled).

Hope these help.

 

AttachmentSize
Image icon Good Scan Overlay.jpg28.61 KB
Image icon Bad Scan Overlay.jpg436.65 KB

Vuforia 4.0 Messed up overlay UI

March 3, 2015 - 12:25pm #4

Thank you. Also, could you provide a few more details:

1. Unity version
2. iOS device model
3. iOS version
4. Observable in Unity PlayMode?
5. NGUI version

 

Vuforia 4.0 Messed up overlay UI

March 3, 2015 - 12:04pm #3

vuforia-unity-mobile-android-ios-4-0-11-beta

Vuforia 4.0 Messed up overlay UI

March 3, 2015 - 12:02pm #2

There were a couple of 4.x beta versions released. Which beta version were you using in your app? Look for the license_3rdpartynotice file in your Unity project to find the SDK version.

Log in or register to post comments