Log in or register to post comments

Vuforia Disables Enabled Target Database when a new Image Target is Added

September 20, 2017 - 10:53pm #1

Vuforia SDK Version: Unity 2017.2 Beta -

Description with steps to reproduce: 1. Create a new Unity Project
2. Enable Vuforia, and copy in your Dev Key.
3. Add an AR camera.
4. Delete the Scene Camera.
5. Load in a custom image target Database.
6. Disable all loaded Databases (Mars) and enable and load your custom image target database.
7. Add a new image target.
> The texture / target defaults to something from the Mars database.
8. Choose your custom DB and one of your targets.
9. Run your game.
ISSUE: Your tracker isn't recognized.
10. Stop your game.
11. Go to the Vuforia Configuration panel.
BUG: Your custom image target database is disabled! Instead, the Mars Databases are enabled and loaded.

This caused me no shortage of consternation as I had already double-checked my database settings before running the game - I definitely didn't expect them to rever when I added my image targets. -

Development OS (Mac OS X, Windows, Linux): OS X -

Mobile OS and Version: N/A -

Mobile Device Manufacturer and Model name: N/A -

Do the Vuforia Sample Applications show the same behavior?: The sample applications use the Mars Databases, so it would be hard to tell.

Vuforia Disables Enabled Target Database when a new Image Target is Added

September 22, 2017 - 2:55pm #3

Yes, I was eventually able to get it working - but it was certainly a stumper for myself and many of my students. Even after calling it out as an issue, and fixing it, many folks ran into it again after adding a new image target to their scene.

Vuforia Disables Enabled Target Database when a new Image Target is Added

September 21, 2017 - 5:35pm #2


Hello dskeith,

I have been able to reproduce this issue and will bring it to the attention of our team. I was able to enable the custom dataset after running through your steps and get the target functioning, were you able to do this as well?

Thanks,

-Vuforia Support

Log in or register to post comments