Log in or register to post comments

Vuforia image detection works on webcam but not on iOS device

February 18, 2021 - 3:50pm #3

Hello, so basically as the title says, I am able to get my vuforia running just fine when I run the application on a simulation on my pc or mac. However, when I build it for my iOS device and open the application on my phone, the vuforia camera shows video but it never detects my image. Any though on this?



I thought it was because I did not enable the vuforia in my xr settings under player but I do not have that option. After some research it says that you no longer have to do that step. So what could be wrong here?

Thanks!



EDIT: So I am realizing that my iOS device is indeed detecting the image but it is placing the image very far away from where it should be. But it does not do this on my webcam?

Vuforia image detection works on webcam but not on iOS device

February 19, 2021 - 12:28am #2

I'm having this same issue with it displaying on my webcam but not ios, were you able to get it sized correctly?

Vuforia image detection works on webcam but not on iOS device

February 19, 2021 - 1:59am #1

Hi @badams44

Please make sure that the GameObject is a child of the Image Target and positioned near the Image Target.

@sherna86

There are a few things to keep in mind if your image will not detect:

1.Import the dataset into Unity: Assets->Import Package->Custom Package...

2.Select the dataset in the ImageTarget prefab: ImageTarget->Image Target Behaviour (Script)->Type = Predefined, select Database and Image Target you want to be detected/tracked

3.Be sure that when building your app, you have selected the scene with the ARCamera+ImageTarget prefab

4.Always print the image that was uploaded to the portal to the exact same aspect ratio. Any stretching or altering of the image will cause it not to be detected. Some printers default to "stretch to fit", which can change the aspect ratio.

5.Check the size values you are using when uploading Targets to the Vuforia Target Manager. Note there is specific language used in the dialogue box that says Vuforia uses meters as the default unit scale. Incorrect target sizes could affect either our detection/tracking algorithm, or the augmentation in that it so large that it cannot be viewed because it extends beyond the clipping plane.

6.Review ADB/xcode logs to see if Vuforia detects and tracks the target. If the target is being tracked but the augmentation cannot be seen, this could indicate an issue with the clipping plane.

Note that the console message "trackable lost" does not indicate that something is wrong.

Thank you.

Vuforia engine Support

Log in or register to post comments