Log in or register to post comments

Vuforia Not Working on iPhone8+

October 12, 2017 - 4:32pm #1

Vuforia SDK Version: 6.5.22 -
Description with steps to reproduce: Unity version 2017.2.0f3

Something is clearly not working right on the iPhone 8+ and image targets. They appear noticeably jittery compared to an iPhone 6s+.
The video below clearly shows it. This is very noticeable and easily reproducible. I would expect an iPhone 8 to at least compare with the tracking quality of a 6s if not exceed it.
I've restarted the app to see if maybe a profile needed downloading or something. I've also tried speed and quality settings with no difference.

If the iPhone 8 is not officially supported yet, please let us know, I didn't see anything in the release notes.


Development OS (Mac OS X, Windows, Linux): 10.12.6 -
Mobile OS and Version: 11.0.3 -
Mobile Device Manufacturer and Model name: iPhone 8+ -
Do the Vuforia Sample Applications show the same behavior?: I didnt bother cause this was literally just an ARcamera, Image Target and Cube, no other scripts or assets.

Vuforia Not Working on iPhone8+

November 1, 2017 - 8:13am #8

I missed this post, patch is working, Thanks!  Also checked 7.0.26 and it seems fixed out of the box, but it's a bit too buggy still to use.


Vuforia Not Working on iPhone8+

October 23, 2017 - 5:01pm #7

Hello dpizzle,

We have uploaded a patch for the iPhone 8+. It will be applied after performing the following:

  1. Make sure that the device's Wifi is enabled and can connect to the Internet
  2. Uninstall your test app with Vuforia integrated
  3. Reinstall the same test app
  4. Start the same test app and let it run in idle state for 30 seconds
  5. Stop the same test app
  6. Restart the same test app

This patch is only valid for Vuforia 6.5. Note that this update will only persist for as long as that version of the test app is installed on that device. Reinstallation of the app on the device *may* over-write the patch. If so, you'll then need to redo the provided steps above.

Upon startup the SDK will attempt to download the patch and apply it before Vuforia camera start. Whether or not this operation completes before first camera start depends entirely on upon app experience, network connectivity and network latency.

This is only for the iPhone 8+ currently, I will let you know the status of the iPhone 7+.


-Vuforia Support

Vuforia Not Working on iPhone8+

October 17, 2017 - 2:13pm #6

Thank you so much,  here's some steps to reproduce if it helps.  It's easiest to see on the sample VuMarks, it's there on the sample Image targets, but harder to see (it's more prevalent on some custom image targets more than others, but I couldn't figure out why).

1. Print a sample VuMark

2. Load VuMark sample in either Unity or native Xcode (problem exists on both).  Then place 3d object on VuMark so you can see the jitter.

3. Launch app and place iPhone in a stand about 30 degrees tilted down in front of VuMark.

Let me know if you need any more info.


Vuforia Not Working on iPhone8+

October 17, 2017 - 10:33am #5

Hello dpizzle,

We are looking into your report and I will post here with any news I have to share.


-Vuforia Support

Vuforia Not Working on iPhone8+

October 16, 2017 - 10:28am #4

More video showing it, this time on VuMarks: http://relativedistance.com/VuforiaTest2.mp4

It doesnt seem to affect the front facing camera.  Did something change internally from these two iPhones, maybe Vuforia is sampling a higher resolution which is making it more sensitive?

I couldn't figure out how to turn off image stabiization with a native plugin, if it's even on, not sure.  

Can we get a confirmation that this is on your radar as an issue?



Vuforia Not Working on iPhone8+

October 13, 2017 - 3:24am #3

After more research, my gut says:

This is also present on the iPhone 7+ given the camera similarities


It has something to do with Optical Image Stabilization (OIS), Focus Pixels,  or Cinematic Video Stabilization

I guess it's time to write a native plugin to change these settings (which I hope is possible).  I'll report back here If i can solve it.

Would love to get a few words from an engineer on it, if someone had the time.


Vuforia Not Working on iPhone8+

October 12, 2017 - 6:44pm #2

Did some more testing.  The discrepancy between the two devices tracking quality also exists in Unity 5.6/ Vuforia 6.2.10.

It has nothing to do with focus mode. I tried them all.  Also, the jitter issue was the same no matter how in focus or out of focus the image target was, which I find very odd.    

Again the iPhone 6s+ is rock solid and flawless tracking no matter what, not so with the iPhone 8+.

BTW, target is 5 stars.



Log in or register to post comments