Topic locked

Vuforia plug-in won't compile in Unity 5.3: TypeLoadException

February 29, 2016 - 2:09pm #1

Vuforia SDK Version: 5 -
Description with steps to reproduce:

I updated my old Vuforia project to Unity 5.3 and the latest version of the Vuforia plug-in and I see this error twice in the console:

TypeLoadException: Could not load type 'Vuforia.DataSetLoadAbstractBehaviour' from assembly 'Qualcomm.Vuforia.UnityExtensions, Version=0.0.0.0, Culture=neutral, PublicKeyToken=null'.
 
The scripts attached to the ARCamera won't expand in the inspector so I can't add my license key--which I suspect is due to this compilation error
 
I tried this in 5.3, 5.3p1, and 5.4p7
 
This worked fine in previous versions of Unity / Vuforia.

-
Development OS (Mac OS X, Windows, Linux): Mac OSX -
Mobile OS and Version: iOS 9 -
Mobile Device Manufacturer and Model name: Apple iPhone 6 -
Do the Vuforia Sample Applications show the same behavior?: No.

Vuforia plug-in won't compile in Unity 5.3: TypeLoadException

March 9, 2016 - 10:35am #3

UPDATE: Vuforia 5.5.9 has been released and supports Unity 5.3.2 and 5.3.3:

https://developer.vuforia.com/library/articles/Release_Notes/Vuforia-SDK-Release-Notes

https://developer.vuforia.com/downloads/sdk

Also, make sure to check the Unity Migration Guide before upgrading to Vuforia 5.5:

https://developer.vuforia.com/library/articles/Solution/Migrating-Unity-Projects-to-Vuforia-5-5

Vuforia plug-in won't compile in Unity 5.3: TypeLoadException

March 6, 2016 - 3:22am #2

The error message:

TypeLoadException: Could not load type 'Vuforia.DataSetLoadAbstractBehaviour' from assembly 'Qualcomm.Vuforia.UnityExtensions, Version=0.0.0.0, Culture=neutral, PublicKeyToken=null'.
 

indicates that your project seems to be trying to access an old Vuforia API "DataSetLoadAbstractBehaviour"; such API is no longer available in Vuforia 5.0.x; 

probably you are still using an old version of Vuforia, such as Vuforia 4.0.x or 4.2.x, which do not support Unity 5.3;

 

in order to suport Unity 5.3, you need to first upgrade Vuforia to the latest Vuforia 5.0.10, and then upgrade your Unity version to Unity 5.3;

 

for a correct migration, see this:

https://developer.vuforia.com/library/articles/Solution/Migrating-Unity-Projects-to-Vuforia-5

 

also, be aware that Vuforia 5.0.10 supports Unity 5.3 up to (and including) 5.3.1, but it does not support Unity 5.3.2 or 5.3.3 (these will be supported in the next version of Vuforia 5.x):

see this:

https://developer.vuforia.com/forum/unity-extension-technical-discussion/notice-unity-532-incompatible-vuforia

 

Topic locked